summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2024-10-15 22:31:08 +0200
committerSam James <sam@gentoo.org>2024-11-06 13:35:14 +0000
commit4777ea448c6b0d289068b3acd371c50e6844cb6b (patch)
tree48b16401588f35e52fd0d73b95e510fcc0d79572 /sys-cluster
parentapp-text/yelp-tools: enable py3.13 (diff)
downloadgentoo-4777ea448c6b0d289068b3acd371c50e6844cb6b.tar.gz
gentoo-4777ea448c6b0d289068b3acd371c50e6844cb6b.tar.bz2
gentoo-4777ea448c6b0d289068b3acd371c50e6844cb6b.zip
sys-cluster/charliecloud: don't pass -W to sphinx-build
This effectively works like -Werror and causes build failures such as #941591 from simple deprecation warnings. Closes: https://bugs.gentoo.org/941591 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Closes: https://github.com/gentoo/gentoo/pull/39006 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.38.ebuild2
-rw-r--r--sys-cluster/charliecloud/charliecloud-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/sys-cluster/charliecloud/charliecloud-0.38.ebuild b/sys-cluster/charliecloud/charliecloud-0.38.ebuild
index e77a512214ec..763a64f92697 100644
--- a/sys-cluster/charliecloud/charliecloud-0.38.ebuild
+++ b/sys-cluster/charliecloud/charliecloud-0.38.ebuild
@@ -55,6 +55,8 @@ DEPEND="
src_prepare() {
default
+ # Remove -W from SPHINXOPTS to prevent failure due to warnings
+ sed -i 's#^SPHINXOPTS .*=.*#SPHINXOPTS =#' doc/Makefile.am || die "Makefile patching failed"
eautoreconf
}
diff --git a/sys-cluster/charliecloud/charliecloud-9999.ebuild b/sys-cluster/charliecloud/charliecloud-9999.ebuild
index a6b170a769bb..820cc3aa74cb 100644
--- a/sys-cluster/charliecloud/charliecloud-9999.ebuild
+++ b/sys-cluster/charliecloud/charliecloud-9999.ebuild
@@ -57,6 +57,8 @@ DEPEND="
src_prepare() {
default
+ # Remove -W from SPHINXOPTS to prevent failure due to warnings
+ sed -i 's#^SPHINXOPTS .*=.*#SPHINXOPTS =#' doc/Makefile.am || die "Makefile patching failed"
eautoreconf
}