summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2024-11-02 14:15:02 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-11-02 14:45:59 +0200
commit5e4f560e8d971b815d6688926714841988074738 (patch)
tree0403f174118f3de1ff56fb1d5d036a004dd748e0 /sys-cluster
parentsys-cluster/charliecloud: drop 0.37 (diff)
downloadgentoo-5e4f560e8d971b815d6688926714841988074738.tar.gz
gentoo-5e4f560e8d971b815d6688926714841988074738.tar.bz2
gentoo-5e4f560e8d971b815d6688926714841988074738.zip
sys-cluster/charliecloud: re revbump
- tarballs are identical, no change of installed files etc. Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/charliecloud/Manifest1
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.38-r1.ebuild95
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.38.ebuild6
3 files changed, 3 insertions, 99 deletions
diff --git a/sys-cluster/charliecloud/Manifest b/sys-cluster/charliecloud/Manifest
index 289bea5fc878..c24dd6179c3b 100644
--- a/sys-cluster/charliecloud/Manifest
+++ b/sys-cluster/charliecloud/Manifest
@@ -1,2 +1 @@
DIST charliecloud-0.38.tar.bz2 538394 BLAKE2B 8ecc0564ba4d9a66f04d48cbcc3d658e582d283b67876a7fe1d697c22417339d13cec60550299725950578a6755c8f640087f03dae424dc9aca2ba38a05c1094 SHA512 2bbc681bb2e2199400f245996be9417c832ccbc2d4df185b4c1d82ac03c800cff414cf9a882376e61ca78866e4ddcb34e6f01d5d49aa54fa0f069800707c6952
-DIST charliecloud-0.38.tar.gz 616115 BLAKE2B 62126c9f57b1a0f63b530c29781cc85db9e53da82294eaafc8847cfebad8dd3e62b314de3e1ff0339304e176065793e8ec23509ec03aea04f0f36d2624f5ae0d SHA512 aa92ed71e93656318954db974e67312f0a912391ba166f1a38e8871511811a4a1810c6769d79afbb66cab6ffbe89f46a2238fbe7cd5a961fd9ebabe152c3ac18
diff --git a/sys-cluster/charliecloud/charliecloud-0.38-r1.ebuild b/sys-cluster/charliecloud/charliecloud-0.38-r1.ebuild
deleted file mode 100644
index e77a512214ec..000000000000
--- a/sys-cluster/charliecloud/charliecloud-0.38-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit autotools optfeature python-single-r1
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/${PN}/main.git"
-else
- SRC_URI="https://gitlab.com/${PN}/main/-/archive/v${PV}/main-v${PV}.tar.bz2 -> ${P}.tar.bz2"
- KEYWORDS="~amd64 ~x86 ~x86-linux"
- S="${WORKDIR}/main-v${PV}"
-fi
-
-DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
-HOMEPAGE="https://hpc.github.io/charliecloud/"
-LICENSE="Apache-2.0"
-
-SLOT="0"
-IUSE="ch-image doc"
-
-# Extensive test suite exists, but downloads container images
-# directly and via Docker and installs packages inside using apt/yum.
-# Additionally, clashes with portage namespacing and sandbox.
-RESTRICT="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-BDEPEND="
- virtual/pkgconfig
-"
-RDEPEND="${PYTHON_DEPS}
- elibc_musl? ( sys-libs/argp-standalone )
-"
-DEPEND="
- ch-image? (
- $(python_gen_cond_dep '
- dev-python/lark[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ')
- dev-vcs/git
- net-misc/rsync
- )
- doc? (
- $(python_gen_cond_dep '
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
- ')
- net-misc/rsync
- )"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local econf_args=(
- $(use_enable doc html)
- $(use_enable ch-image)
- # Libdir is used as a libexec-style destination.
- --libdir="${EPREFIX}"/usr/lib
- # Attempts to call python-exec directly otherwise.
- --with-sphinx-python="${EPYTHON}"
- # This disables -Werror, see also: https://github.com/hpc/charliecloud/pull/808
- --enable-buggy-build
- # Do not use bundled version of dev-python/lark.
- --disable-bundled-lark
- # Use correct shebang.
- --with-python="${PYTHON}"
- # Disable configure checks vor OverlayFS causing sandbox violations.
- --disable-impolite-checks
- )
- econf "${econf_args[@]}"
-}
-
-src_install() {
- docompress -x "${EPREFIX}"/usr/share/doc/"${PF}"/examples
- default
-}
-
-pkg_postinst() {
- elog "Various builders are supported, as alternative to the internal ch-image."
- optfeature "Building with Buildah" app-containers/buildah
- optfeature "Building with Docker" app-containers/docker
- optfeature "Building with Podman" app-containers/podman
- optfeature "Progress bars during long operations" sys-apps/pv
- optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
- optfeature "Mount and umount squashfs images" sys-fs/squashfuse
- optfeature "Build versioning with ch-image" dev-vcs/git
-}
diff --git a/sys-cluster/charliecloud/charliecloud-0.38.ebuild b/sys-cluster/charliecloud/charliecloud-0.38.ebuild
index eac024093be7..e77a512214ec 100644
--- a/sys-cluster/charliecloud/charliecloud-0.38.ebuild
+++ b/sys-cluster/charliecloud/charliecloud-0.38.ebuild
@@ -9,11 +9,11 @@ inherit autotools optfeature python-single-r1
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
- S="${WORKDIR}/${P}"
+ EGIT_REPO_URI="https://gitlab.com/${PN}/main.git"
else
- SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://gitlab.com/${PN}/main/-/archive/v${PV}/main-v${PV}.tar.bz2 -> ${P}.tar.bz2"
KEYWORDS="~amd64 ~x86 ~x86-linux"
+ S="${WORKDIR}/main-v${PV}"
fi
DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"