summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-06-01 12:14:09 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-06-01 12:14:48 -0700
commit8f0f8a7ad1f00acef2416ea918d0b6ed978a8e63 (patch)
tree65a72dab239d10178caadb66285e3a5b403d3389 /sys-cluster
parentprofiles/arch/powerpc/ppc64: drop noto-emoji[buildfont] mask, bug #716074 (diff)
downloadgentoo-8f0f8a7ad1f00acef2416ea918d0b6ed978a8e63.tar.gz
gentoo-8f0f8a7ad1f00acef2416ea918d0b6ed978a8e63.tar.bz2
gentoo-8f0f8a7ad1f00acef2416ea918d0b6ed978a8e63.zip
sys-cluster/ceph-15.2.3: Fix build with USE=spdk
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ceph-15.2.3.ebuild1
-rw-r--r--sys-cluster/ceph/files/ceph-15.2.3-spdk-compile.patch9
2 files changed, 10 insertions, 0 deletions
diff --git a/sys-cluster/ceph/ceph-15.2.3.ebuild b/sys-cluster/ceph/ceph-15.2.3.ebuild
index 6b0fa3f4c3b2..dc22c44fea61 100644
--- a/sys-cluster/ceph/ceph-15.2.3.ebuild
+++ b/sys-cluster/ceph/ceph-15.2.3.ebuild
@@ -194,6 +194,7 @@ PATCHES=(
"${FILESDIR}/ceph-14.2.0-cython-0.29.patch"
"${FILESDIR}/ceph-15.2.0-rocksdb-cmake.patch"
"${FILESDIR}/ceph-15.2.2-systemd-unit.patch"
+ "${FILESDIR}/ceph-15.2.3-spdk-compile.patch"
)
check-reqs_export_vars() {
diff --git a/sys-cluster/ceph/files/ceph-15.2.3-spdk-compile.patch b/sys-cluster/ceph/files/ceph-15.2.3-spdk-compile.patch
new file mode 100644
index 000000000000..3ea6eadbb86f
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-15.2.3-spdk-compile.patch
@@ -0,0 +1,9 @@
+--- ceph-15.2.3.orig/cmake/modules/BuildSPDK.cmake 2020-05-29 09:24:50.000000000 -0700
++++ ceph-15.2.3/cmake/modules/BuildSPDK.cmake 2020-06-01 10:36:14.629306433 -0700
+@@ -1,5 +1,5 @@
+ macro(build_spdk)
+- set(DPDK_DIR ${CMAKE_BINARY_DIR}/src/dpdk)
++ set(DPDK_DIR ${CMAKE_SOURCE_DIR}/src/dpdk)
+ if(NOT TARGET dpdk-ext)
+ include(BuildDPDK)
+ build_dpdk(${DPDK_DIR})