summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-01-23 08:04:11 -0500
committerAnthony G. Basile <blueness@gentoo.org>2016-01-23 08:04:49 -0500
commit80f13d75b2bbc3e99f1cd0af3a5c20004859ce88 (patch)
tree02ad5753f06bd20a61f10ae452107f90d6a789fe /sys-fs/f2fs-tools/f2fs-tools-1.6.0.ebuild
parentwww-apps/jekyll-sitemap: Version bump (diff)
downloadgentoo-80f13d75b2bbc3e99f1cd0af3a5c20004859ce88.tar.gz
gentoo-80f13d75b2bbc3e99f1cd0af3a5c20004859ce88.tar.bz2
gentoo-80f13d75b2bbc3e99f1cd0af3a5c20004859ce88.zip
sys-fs/f2fs-tools: version bump to 1.6.0, bug #572674
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-fs/f2fs-tools/f2fs-tools-1.6.0.ebuild')
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.6.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.6.0.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.6.0.ebuild
new file mode 100644
index 000000000000..793c43db22ce
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.6.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/jaegeuk/f2fs-tools.git;a=summary"
+SRC_URI="https://dev.gentoo.org/~blueness/f2fs-tools/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+src_configure() {
+ #This is required to install to /sbin, bug #481110
+ econf --prefix=/ --includedir=/usr/include
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/$(get_libdir)/libf2fs.{,l}a
+ rm -f "${ED}"/$(get_libdir)/libf2fs_format.{,l}a
+}