summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/genext2fs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/genext2fs')
-rw-r--r--sys-fs/genext2fs/Manifest4
-rw-r--r--sys-fs/genext2fs/genext2fs-1.3-r1.ebuild33
-rw-r--r--sys-fs/genext2fs/genext2fs-1.4.1.ebuild19
-rw-r--r--sys-fs/genext2fs/genext2fs-1.4.ebuild19
-rw-r--r--sys-fs/genext2fs/metadata.xml8
5 files changed, 83 insertions, 0 deletions
diff --git a/sys-fs/genext2fs/Manifest b/sys-fs/genext2fs/Manifest
new file mode 100644
index 000000000000..f9342228ae54
--- /dev/null
+++ b/sys-fs/genext2fs/Manifest
@@ -0,0 +1,4 @@
+DIST genext2fs-1.3-uclibc-updates.patch.bz2 20048 SHA256 dd9b1e1afc146328deaa4440560e37fc9b527324aea4a347fa28a1025d442315
+DIST genext2fs-1.4.1.tar.gz 103283 SHA256 404dbbfa7a86a6c3de8225c8da254d026b17fd288e05cec4df2cc7e1f4feecfc SHA512 1b9ec7044014423345ae6b09862ba6903f5b3e0f68fb8bbcf97daf2705471cc1633a9fdbc5e00afe1b191e1af7bed87bde2e538bc7365469218f2a00b062845c WHIRLPOOL c92cda39f10b988ae753fcd8b70c7abd687832f96f2b80322e55ae560e73657ceb0eaad62b190fb538976151d6c9278ad859848fe190e97b366f0cabb21fae2c
+DIST genext2fs-1.4.tar.gz 101384 SHA256 b48b7f01f493fc4f977778e6c368f6916a8c6bf7f9d6a6ff910ff364d725b9b5
+DIST genext2fs_1.3.orig.tar.gz 19343 SHA256 8e7dfa34f3919226550dc6507a23753f9fda55e78b15b264291ecf5940d837e9
diff --git a/sys-fs/genext2fs/genext2fs-1.3-r1.ebuild b/sys-fs/genext2fs/genext2fs-1.3-r1.ebuild
new file mode 100644
index 000000000000..e93bd4ddfec6
--- /dev/null
+++ b/sys-fs/genext2fs/genext2fs-1.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="generate ext2 file systems"
+HOMEPAGE="http://sourceforge.net/projects/genext2fs"
+SRC_URI="mirror://debian/pool/main/g/genext2fs/${PN}_${PV}.orig.tar.gz
+ mirror://gentoo/${P}-uclibc-updates.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha arm hppa ~mips ppc sparc x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${P}.orig
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${P}-uclibc-updates.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+}
diff --git a/sys-fs/genext2fs/genext2fs-1.4.1.ebuild b/sys-fs/genext2fs/genext2fs-1.4.1.ebuild
new file mode 100644
index 000000000000..11a5e249f532
--- /dev/null
+++ b/sys-fs/genext2fs/genext2fs-1.4.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="generate ext2 file systems"
+HOMEPAGE="http://sourceforge.net/projects/genext2fs"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ~mips ppc sparc x86"
+IUSE=""
+
+DEPEND=""
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/sys-fs/genext2fs/genext2fs-1.4.ebuild b/sys-fs/genext2fs/genext2fs-1.4.ebuild
new file mode 100644
index 000000000000..12f86ad9b32d
--- /dev/null
+++ b/sys-fs/genext2fs/genext2fs-1.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="generate ext2 file systems"
+HOMEPAGE="http://sourceforge.net/projects/genext2fs"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/sys-fs/genext2fs/metadata.xml b/sys-fs/genext2fs/metadata.xml
new file mode 100644
index 000000000000..039dac4acd36
--- /dev/null
+++ b/sys-fs/genext2fs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dev-embedded</herd>
+ <upstream>
+ <remote-id type="sourceforge">genext2fs</remote-id>
+ </upstream>
+</pkgmetadata>