summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/s3fs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/s3fs')
-rw-r--r--sys-fs/s3fs/Manifest2
-rw-r--r--sys-fs/s3fs/metadata.xml12
-rw-r--r--sys-fs/s3fs/s3fs-1.74.ebuild26
-rw-r--r--sys-fs/s3fs/s3fs-1.78.ebuild35
4 files changed, 75 insertions, 0 deletions
diff --git a/sys-fs/s3fs/Manifest b/sys-fs/s3fs/Manifest
new file mode 100644
index 000000000000..250bcb88e78a
--- /dev/null
+++ b/sys-fs/s3fs/Manifest
@@ -0,0 +1,2 @@
+DIST s3fs-1.74.tar.gz 199120 SHA256 d77d540582fe8287354fd3637e48064f81f6fe80c5f0e0f8253221c56b892b88 SHA512 c9f6e2a113d2cfb9d6ac485d58ae8ebf317b9fc29b2fab34de427f206902eda22de056cbcdbc0e8cdebeff7900793e96a87f4ad8a3b1add85433a617ba53889d WHIRLPOOL 3572602fb3fe71e1e17d46925fc3459623fc7e9dcad1bfeee6120bba5d57005eacccbb87b786af74af62cc3f2ec87dce965a05a4c5645f6b5d035a578c617568
+DIST s3fs-1.78.tar.gz 99538 SHA256 36c0b00a294d9676c462985c0c3f1362540e8ebc61c15bacb45e28a2f00297f5 SHA512 ba0ad1ee5fc3c31d5b98dc7511abc8e74e91649af27aaaf5ecdca76cc7503bf66118638f983199bcdcaa51897f1bfa802310db9e2b72538d9f345f6942a3a8d0 WHIRLPOOL 1c9c5589475c0d545657973d638d51deac3266b0878fe27a114bd3da938455c56d941183783b264e226fa7c4976b357f4009063c985311bcf27749f7b454690f
diff --git a/sys-fs/s3fs/metadata.xml b/sys-fs/s3fs/metadata.xml
new file mode 100644
index 000000000000..e903c6dbb70c
--- /dev/null
+++ b/sys-fs/s3fs/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">s3fs is a utility to mount Amazon S3 as a filesystem over FUSE</longdescription>
+ <upstream>
+ <remote-id type="google-code">s3fs</remote-id>
+ <remote-id type="github">s3fs-fuse/s3fs-fuse</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/s3fs/s3fs-1.74.ebuild b/sys-fs/s3fs/s3fs-1.74.ebuild
new file mode 100644
index 000000000000..b2fe0812df9e
--- /dev/null
+++ b/sys-fs/s3fs/s3fs-1.74.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Amazon mounting S3 via fuse"
+HOMEPAGE="http://s3fs.googlecode.com/"
+SRC_URI="http://s3fs.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+CDEPEND=">=dev-libs/libxml2-2.6:2
+ dev-libs/openssl
+ >=net-misc/curl-7.0
+ >=sys-fs/fuse-2.8.4"
+RDEPEND="${CDEPEND}
+ app-misc/mime-types"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+
+RESTRICT="test"
diff --git a/sys-fs/s3fs/s3fs-1.78.ebuild b/sys-fs/s3fs/s3fs-1.78.ebuild
new file mode 100644
index 000000000000..34cc4f8a7480
--- /dev/null
+++ b/sys-fs/s3fs/s3fs-1.78.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+MY_PN=${PN}-fuse
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Amazon mounting S3 via fuse"
+HOMEPAGE="https://github.com/s3fs-fuse/s3fs-fuse/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND=">=dev-libs/libxml2-2.6:2
+ dev-libs/openssl
+ >=net-misc/curl-7.0
+ >=sys-fs/fuse-2.8.4"
+RDEPEND="${CDEPEND}
+ app-misc/mime-types"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ eautoreconf
+}