summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-04 14:23:11 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-04 14:25:52 +0100
commit62918c71ef476e5e09f94a2291704111e1dd4a3f (patch)
tree36f6730c832e1c40732c7ffb9a019321731012a9 /sys-libs/compiler-rt
parentdev-cpp/notcurses: remove zlib dep (diff)
downloadgentoo-62918c71ef476e5e09f94a2291704111e1dd4a3f.tar.gz
gentoo-62918c71ef476e5e09f94a2291704111e1dd4a3f.tar.bz2
gentoo-62918c71ef476e5e09f94a2291704111e1dd4a3f.zip
sys-libs/compiler-rt: Inline ABI_X86 flags to fix non-x86 arches
Inline ABI_X86 flags instead of using multilib-build, as the latter injects a REQUIRED_USE constraint that is impossible to satisfy on non-x86 architectures. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/compiler-rt')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild6
-rw-r--r--sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild6
-rw-r--r--sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild6
3 files changed, 6 insertions, 12 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild
index ef78484f7721..0a82b041cbde 100644
--- a/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild
@@ -3,10 +3,8 @@
EAPI=7
-MULTILIB_COMPAT=( abi_x86_{32,64} )
PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake flag-o-matic llvm llvm.org multilib-build python-any-r1 \
- toolchain-funcs
+inherit cmake flag-o-matic llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
@@ -14,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
KEYWORDS=""
-IUSE="+clang debug test"
+IUSE="+abi_x86_32 abi_x86_64 +clang debug test"
RESTRICT="!test? ( test ) !clang? ( test )"
CLANG_SLOT=${SLOT%%.*}
diff --git a/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild b/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild
index 59324e768209..3c0553bcebbd 100644
--- a/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild
@@ -3,10 +3,8 @@
EAPI=7
-MULTILIB_COMPAT=( abi_x86_{32,64} )
PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake flag-o-matic llvm llvm.org multilib-build python-any-r1 \
- toolchain-funcs
+inherit cmake flag-o-matic llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
@@ -14,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
KEYWORDS=""
-IUSE="+clang debug test"
+IUSE="+abi_x86_32 abi_x86_64 +clang debug test"
RESTRICT="!test? ( test ) !clang? ( test )"
CLANG_SLOT=${SLOT%%.*}
diff --git a/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild
index f8402de337a2..3d2048549e73 100644
--- a/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild
@@ -3,10 +3,8 @@
EAPI=7
-MULTILIB_COMPAT=( abi_x86_{32,64} )
PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake flag-o-matic llvm llvm.org multilib-build python-any-r1 \
- toolchain-funcs
+inherit cmake flag-o-matic llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
@@ -14,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
KEYWORDS=""
-IUSE="+clang debug test"
+IUSE="+abi_x86_32 abi_x86_64 +clang debug test"
RESTRICT="!test? ( test ) !clang? ( test )"
CLANG_SLOT=${SLOT%%.*}