summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/cracklib/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/cracklib/files')
-rw-r--r--sys-libs/cracklib/files/cracklib-2.9.1-setup.py-srcdir.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-libs/cracklib/files/cracklib-2.9.1-setup.py-srcdir.patch b/sys-libs/cracklib/files/cracklib-2.9.1-setup.py-srcdir.patch
new file mode 100644
index 000000000000..ac69b9f60581
--- /dev/null
+++ b/sys-libs/cracklib/files/cracklib-2.9.1-setup.py-srcdir.patch
@@ -0,0 +1,35 @@
+From 70909dd3d30a13bb0406ca76feea49f05b8b978d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 29 May 2014 23:57:32 +0200
+Subject: [PATCH] Fix paths in setup.py to support out-of-source builds.
+
+---
+ python/setup.py.in | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/python/setup.py.in b/python/setup.py.in
+index 4a258a0..4c70de4 100644
+--- a/python/setup.py.in
++++ b/python/setup.py.in
+@@ -23,8 +23,8 @@ from setuptools import setup, Extension, find_packages
+
+ extensions = [
+ Extension("_cracklib",
+- ["_cracklib.c"],
+- include_dirs = ["@top_builddir@/lib"],
++ ["@srcdir@/_cracklib.c"],
++ include_dirs = ["@top_srcdir@/lib"],
+ libraries = ["crack"],
+ library_dirs = ["@top_builddir@/lib/.libs"]),
+ ]
+@@ -43,6 +43,7 @@ convenience functions.
+ url="http://cracklib.sourceforge.net/",
+ license="GPLv2+",
+ py_modules=['cracklib', 'test_cracklib'],
++ package_dir={'': '@srcdir@'},
+ ext_modules=extensions,
+ zip_safe=False,
+ classifiers=[
+--
+2.0.0
+