summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2020-09-01 19:42:29 +0000
committerJason Zaman <perfinion@gentoo.org>2020-09-14 20:40:11 -0700
commit87de30f50d44b9be299117be09fe22fd195e6fef (patch)
treeedc8938a141ad96b6d3c9bb419dea1075786ff95 /sys-libs/libsepol
parentapp-emulation/gxemul: bump to 0.6.2 (diff)
downloadgentoo-87de30f50d44b9be299117be09fe22fd195e6fef.tar.gz
gentoo-87de30f50d44b9be299117be09fe22fd195e6fef.tar.bz2
gentoo-87de30f50d44b9be299117be09fe22fd195e6fef.zip
sys-libs/libsepol: Version bump to 3.1.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-libs/libsepol')
-rw-r--r--sys-libs/libsepol/Manifest1
-rw-r--r--sys-libs/libsepol/libsepol-3.1.ebuild55
-rw-r--r--sys-libs/libsepol/libsepol-9999.ebuild6
3 files changed, 59 insertions, 3 deletions
diff --git a/sys-libs/libsepol/Manifest b/sys-libs/libsepol/Manifest
index 17ca9f8a9352..07eedac7d743 100644
--- a/sys-libs/libsepol/Manifest
+++ b/sys-libs/libsepol/Manifest
@@ -1,2 +1,3 @@
DIST libsepol-2.9.tar.gz 474861 BLAKE2B 2d0941a003bbe6f15f047e3e55ce4561c36fb4946ce46b618df1b884881579cd192a0ac7cbedfb67ae5e926ab03ca35988d2a4fc279f31a88c83874e85862d13 SHA512 415af623c2b2898d98828c9bf0b12cf05d05790d2b412cad291f0759a8c3feacf1bd88c2ba6f2f1bca8f9f71e1627e9d5b1b69d60e7ef96fdd52df8a3d57d3e9
DIST libsepol-3.0.tar.gz 473864 BLAKE2B ff4da6e12c1635de88a2aaba26bd3630576a3806543d7176d8fbdb4deda5c9c5fbf8a5a4f68c8041cca0af97429e720d908cd31052d13ac72780bc85db1f56c8 SHA512 82a5bae0afd9ae53b55ddcfc9f6dd61724a55e45aef1d9cd0122d1814adf2abe63c816a7ac63b64b401f5c67acb910dd8e0574eec546bed04da7842ab6c3bb55
+DIST libsepol-3.1.tar.gz 473842 BLAKE2B ef1d596c4d53cc0a87e899ef4aeb5bf29c9d6b8303632ddc866c100d30debd8aedd0e8b38cb4ce3141b80421cd914148ff072e492d63dc2dacf03ac2ce59ca5a SHA512 4b5f4e82853ff3e9b4fac2dbdea5c2fc3bb7b508af912217ac4b75da6540fbcd77aa314ab95cd9dfa94fbc4a885000656a663c1a152f65b4cf6970ea0b6034ab
diff --git a/sys-libs/libsepol/libsepol-3.1.ebuild b/sys-libs/libsepol/libsepol-3.1.ebuild
new file mode 100644
index 000000000000..5b122e23e551
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-3.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib toolchain-funcs multilib-minimal
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20200710"
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ eapply_user
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export CC AR RANLIB
+
+ # https://bugs.gentoo.org/706730
+ local -x CFLAGS="${CFLAGS} -fcommon"
+
+ emake \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ install
+}
diff --git a/sys-libs/libsepol/libsepol-9999.ebuild b/sys-libs/libsepol/libsepol-9999.ebuild
index bffc7757949b..5b122e23e551 100644
--- a/sys-libs/libsepol/libsepol-9999.ebuild
+++ b/sys-libs/libsepol/libsepol-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
inherit multilib toolchain-funcs multilib-minimal
MY_P="${P//_/-}"
-MY_RELEASEDATE="20191204"
+MY_RELEASEDATE="20200710"
DESCRIPTION="SELinux binary policy representation library"
HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"