summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-07-25 09:53:47 +0200
committerMichał Górny <mgorny@gentoo.org>2017-07-25 09:57:49 +0200
commitc27cf1977388155050dcf0e11aa94abeb3b92412 (patch)
tree7ca6c8f2c9793dc59af82e96ca3fa4e14be1a60f /sys-libs
parentsys-libs/compiler-rt-sanitizers: Clean old up (diff)
downloadgentoo-c27cf1977388155050dcf0e11aa94abeb3b92412.tar.gz
gentoo-c27cf1977388155050dcf0e11aa94abeb3b92412.tar.bz2
gentoo-c27cf1977388155050dcf0e11aa94abeb3b92412.zip
sys-libs/compiler-rt: Clean old up
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt/Manifest1
-rw-r--r--sys-libs/compiler-rt/compiler-rt-4.0.0.ebuild137
2 files changed, 0 insertions, 138 deletions
diff --git a/sys-libs/compiler-rt/Manifest b/sys-libs/compiler-rt/Manifest
index f9fb630a53bd..891526c4b5a8 100644
--- a/sys-libs/compiler-rt/Manifest
+++ b/sys-libs/compiler-rt/Manifest
@@ -1,2 +1 @@
-DIST compiler-rt-4.0.0.src.tar.xz 1435104 SHA256 d3f25b23bef24c305137e6b44f7e81c51bbec764c119e01512a9bd2330be3115 SHA512 ed52436a2399ca82c1af46a523e89e88c23367f74cd110f0267af49a72aa4912ae8f48c6093e6b01c9ea68c48354a12201d26baf721d254fb017ddb98af2e3dd WHIRLPOOL ea5d6fbb34809067825306b1158979946c43c8aec458d946f8c853f3c0e0cd72a6c92a8e4ad8d1b35e10f9bd079a73dd26fde368f919937ad413bdfd83ab4018
DIST compiler-rt-4.0.1.src.tar.xz 1434100 SHA256 a3c87794334887b93b7a766c507244a7cdcce1d48b2e9249fc9a94f2c3beb440 SHA512 cfeb625884b273f7c0e6767b81a8d3e5f24e0b96a510d5764d9d47a0e215fc841b4cb9d1843c8fb428cd21def720cfbfe8d3593ff5bb390548ebc8c32a902649 WHIRLPOOL 8b33c6841cacefe98da92435418b13b8f8ed97a982903be827e5c37f937dc9001975d6a709d60423b21509dd5670ee2e90cb34c96473fb4a66c2ab6f47af09e5
diff --git a/sys-libs/compiler-rt/compiler-rt-4.0.0.ebuild b/sys-libs/compiler-rt/compiler-rt-4.0.0.ebuild
deleted file mode 100644
index 00141f900ff2..000000000000
--- a/sys-libs/compiler-rt/compiler-rt-4.0.0.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-# (needed due to CMAKE_BUILD_TYPE != Gentoo)
-CMAKE_MIN_VERSION=3.7.0-r1
-PYTHON_COMPAT=( python2_7 )
-
-# TODO: fix unnecessary dep on Python upstream
-inherit cmake-utils flag-o-matic llvm python-any-r1 toolchain-funcs
-
-DESCRIPTION="Compiler runtime library for clang (built-in part)"
-HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV/_//}/${P/_/}.src.tar.xz"
-
-LICENSE="|| ( UoI-NCSA MIT )"
-SLOT="${PV%_*}"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="+clang test"
-
-LLVM_SLOT=${SLOT%%.*}
-RDEPEND="!=sys-libs/compiler-rt-${SLOT}*:0"
-# llvm-4 needed for --cmakedir
-DEPEND="
- >=sys-devel/llvm-4
- clang? ( sys-devel/clang )
- test? ( =sys-devel/clang-${PV%_*}*:${LLVM_SLOT} )
- ${PYTHON_DEPS}"
-
-S=${WORKDIR}/${P/_/}.src
-
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
-pkg_setup() {
- llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
-test_compiler() {
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c - \
- <<<'int main() { return 0; }' &>/dev/null
-}
-
-src_configure() {
- # pre-set since we need to pass it to cmake
- BUILD_DIR=${WORKDIR}/${P}_build
-
- if use clang; then
- local -x CC=${CHOST}-clang
- local -x CXX=${CHOST}-clang++
- # ensure we can use clang before installing compiler-rt
- local -x LDFLAGS="${LDFLAGS} -nodefaultlibs -lc"
- strip-unsupported-flags
- elif ! test_compiler; then
- local extra_flags=( -nodefaultlibs -lc )
- if test_compiler "${extra_flags[@]}"; then
- local -x LDFLAGS="${LDFLAGS} ${extra_flags[*]}"
- ewarn "${CC} seems to lack runtime, trying with ${extra_flags[*]}"
- fi
- fi
-
- local mycmakeargs=(
- -DCOMPILER_RT_INSTALL_PATH="${EPREFIX}/usr/lib/clang/${SLOT}"
- # use a build dir structure consistent with install
- # this makes it possible to easily deploy test-friendly clang
- -DCOMPILER_RT_OUTPUT_DIR="${BUILD_DIR}/lib/clang/${SLOT}"
-
- # currently lit covers only sanitizer tests
- -DCOMPILER_RT_INCLUDE_TESTS=OFF
- -DCOMPILER_RT_BUILD_SANITIZERS=OFF
- -DCOMPILER_RT_BUILD_XRAY=OFF
- )
-
- cmake-utils_src_configure
-}
-
-src_test() {
- # prepare a test compiler
- # copy clang over since resource_dir is located relatively to binary
- # therefore, we can put our new libraries in it
- mkdir -p "${BUILD_DIR}"/lib/{llvm/${LLVM_SLOT}{/bin,$(get_libdir)},clang/${SLOT}/include} || die
- cp "${EPREFIX}"/usr/lib/llvm/${LLVM_SLOT}/bin/clang{,++} \
- "${BUILD_DIR}"/lib/llvm/${LLVM_SLOT}/bin/ || die
- cp "${EPREFIX}/usr/lib/clang/${SLOT}/include"/*.h \
- "${BUILD_DIR}/lib/clang/${SLOT}/include/" || die
-
- # builtins are not converted to lit yet, so run them manually
- local tests=() f
- cd "${S}"/test/builtins/Unit || die
- while read -r -d '' f; do
- # ppc subdir is unmaintained and lacks proper guards
- # (and ppc builtins do not seem to be used anyway)
- [[ ${f} == ./ppc/* ]] && continue
- # these are special
- [[ ${f} == ./cpu_model_test.c ]] && continue
- [[ ${f} == ./gcc_personality_test.c ]] && continue
- # unsupported
- [[ ${f} == ./trampoline_setup_test.c ]] && continue
- tests+=( "${f%.c}" )
- done < <(find -name '*.c' -print0)
-
- {
- echo "check: ${tests[*]/#/check-}" &&
- echo ".PHONY: check ${tests[*]/#/check-}" &&
- for f in "${tests[@]}"; do
- echo "check-${f}: ${f}" &&
- echo " ${f}"
- done
- } > Makefile || die
-
- local ABI
- for ABI in $(get_all_abis); do
- # not supported at all at the moment
- [[ ${ABI} == x32 ]] && continue
-
- rm -f "${tests[@]}" || die
-
- einfo "Running tests for ABI=${ABI}"
- # use -k to run all tests even if some fail
- emake -k \
- CC="${BUILD_DIR}/lib/llvm/${LLVM_SLOT}/bin/clang" \
- CFLAGS="$(get_abi_CFLAGS)" \
- CPPFLAGS='-I../../../lib/builtins' \
- LDFLAGS='-rtlib=compiler-rt' \
- LDLIBS='-lm'
- done
-}
-
-src_install() {
- cmake-utils_src_install
-
- # includes are mistakenly installed for all sanitizers and xray
- rm -rf "${ED}"usr/lib/clang/*/include || die
-}