summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-09-15 23:14:46 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-09-15 23:15:24 +0100
commitd1cd3ed5e4670b1c71b4519256ffd0f9b73642df (patch)
treed90d22b229ec9661a58565be377cc3338c5f7e90 /sys-libs
parentdev-python/tenacity: 6.2.0 bump (diff)
downloadgentoo-d1cd3ed5e4670b1c71b4519256ffd0f9b73642df.tar.gz
gentoo-d1cd3ed5e4670b1c71b4519256ffd0f9b73642df.tar.bz2
gentoo-d1cd3ed5e4670b1c71b4519256ffd0f9b73642df.zip
sys-libs/glibc: extend -mcpu= filter from ppc to ppc+ppc64
glibc shares CPU detection code for powerpc/powerpc64. gcc-10 will advertise G5 as power7: $ echo 'int main(){}' | powerpc64-unknown-linux-gnu-gcc \ -mcpu=970 -S -x c - -o - | fgrep machine .machine power7 which is too high for multiarch. Bug: https://sourceware.org/PR26522 Bug: https://bugs.gentoo.org/737996 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.31-r6.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.31-r7.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.32-r1.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.32.ebuild2
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild2
5 files changed, 5 insertions, 5 deletions
diff --git a/sys-libs/glibc/glibc-2.31-r6.ebuild b/sys-libs/glibc/glibc-2.31-r6.ebuild
index fab85b6f35d4..671c8ee63a2b 100644
--- a/sys-libs/glibc/glibc-2.31-r6.ebuild
+++ b/sys-libs/glibc/glibc-2.31-r6.ebuild
@@ -301,7 +301,7 @@ setup_target_flags() {
# The mips abi cannot support the GNU style hashes. #233233
filter-ldflags -Wl,--hash-style=gnu -Wl,--hash-style=both
;;
- ppc)
+ ppc|ppc64)
# Many arch-specific implementations do not work on ppc with
# cache-block not equal to 128 bytes. This breaks memset:
# https://sourceware.org/PR26522
diff --git a/sys-libs/glibc/glibc-2.31-r7.ebuild b/sys-libs/glibc/glibc-2.31-r7.ebuild
index 91c98436a194..07f25009bd18 100644
--- a/sys-libs/glibc/glibc-2.31-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.31-r7.ebuild
@@ -301,7 +301,7 @@ setup_target_flags() {
# The mips abi cannot support the GNU style hashes. #233233
filter-ldflags -Wl,--hash-style=gnu -Wl,--hash-style=both
;;
- ppc)
+ ppc|ppc64)
# Many arch-specific implementations do not work on ppc with
# cache-block not equal to 128 bytes. This breaks memset:
# https://sourceware.org/PR26522
diff --git a/sys-libs/glibc/glibc-2.32-r1.ebuild b/sys-libs/glibc/glibc-2.32-r1.ebuild
index b51024529ad6..18d94a7b0ef0 100644
--- a/sys-libs/glibc/glibc-2.32-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.32-r1.ebuild
@@ -302,7 +302,7 @@ setup_target_flags() {
# The mips abi cannot support the GNU style hashes. #233233
filter-ldflags -Wl,--hash-style=gnu -Wl,--hash-style=both
;;
- ppc)
+ ppc|ppc64)
# Many arch-specific implementations do not work on ppc with
# cache-block not equal to 128 bytes. This breaks memset:
# https://sourceware.org/PR26522
diff --git a/sys-libs/glibc/glibc-2.32.ebuild b/sys-libs/glibc/glibc-2.32.ebuild
index 062f5445621b..bf2ba5df8529 100644
--- a/sys-libs/glibc/glibc-2.32.ebuild
+++ b/sys-libs/glibc/glibc-2.32.ebuild
@@ -301,7 +301,7 @@ setup_target_flags() {
# The mips abi cannot support the GNU style hashes. #233233
filter-ldflags -Wl,--hash-style=gnu -Wl,--hash-style=both
;;
- ppc)
+ ppc|ppc64)
# Many arch-specific implementations do not work on ppc with
# cache-block not equal to 128 bytes. This breaks memset:
# https://sourceware.org/PR26522
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 2319a1e03424..643e0b3883cd 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -302,7 +302,7 @@ setup_target_flags() {
# The mips abi cannot support the GNU style hashes. #233233
filter-ldflags -Wl,--hash-style=gnu -Wl,--hash-style=both
;;
- ppc)
+ ppc|ppc64)
# Many arch-specific implementations do not work on ppc with
# cache-block not equal to 128 bytes. This breaks memset:
# https://sourceware.org/PR26522