summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/schedtool
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/schedtool')
-rw-r--r--sys-process/schedtool/Manifest1
-rw-r--r--sys-process/schedtool/metadata.xml8
-rw-r--r--sys-process/schedtool/schedtool-1.3.0-r1.ebuild29
3 files changed, 38 insertions, 0 deletions
diff --git a/sys-process/schedtool/Manifest b/sys-process/schedtool/Manifest
new file mode 100644
index 000000000000..3eb58253c1a8
--- /dev/null
+++ b/sys-process/schedtool/Manifest
@@ -0,0 +1 @@
+DIST schedtool-1.3.0.tar.bz2 26531 SHA256 4e002a2a619d592f7c9b9d284381ffc004d8a71c38945aa95d5d53f2e4c0c8cf SHA512 1ae39a7b9481cf4062740343cd31289117610041546a7969fde7ae3bed3c1a06cd258dffaeafc4326c9115e37878b943d5abec222e25e45e2a5f76c65adf3b6a WHIRLPOOL 112683b5d2e46b36a058097c53902083594d61d0de26a527cdaff0e2040dfcf06418ba575ba37378c5ef8593750f702b8511c296e67e011e97ff4555f1c717b2
diff --git a/sys-process/schedtool/metadata.xml b/sys-process/schedtool/metadata.xml
new file mode 100644
index 000000000000..c50bcbc70dc8
--- /dev/null
+++ b/sys-process/schedtool/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kernel-misc</herd>
+ <longdescription>
+ schedtool can be used to query or alter a process' scheduling policy under linux
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-process/schedtool/schedtool-1.3.0-r1.ebuild b/sys-process/schedtool/schedtool-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..2d5866c9d105
--- /dev/null
+++ b/sys-process/schedtool/schedtool-1.3.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tool to query or alter a process' scheduling policy"
+HOMEPAGE="http://freequaos.host.sk/schedtool"
+SRC_URI="http://freequaos.host.sk/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT=0
+KEYWORDS="amd64 ~mips ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_prepare() {
+ sed -i '/^CFLAGS=/d;/^install:/s/install-doc//' Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTPREFIX="${ED}"/usr install
+ dodoc CHANGES INSTALL PACKAGERS README SCHED_DESIGN TODO TUNING
+}