summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZ. Liu <zhixu.liu@gmail.com>2024-08-24 00:35:50 +0800
committerMike Gilbert <floppym@gentoo.org>2024-09-05 10:40:12 -0400
commitf0506961c5d9a3edacdf0bfe041fc84753665e4f (patch)
tree1dfa1e43b10c7169418befd624be8b22054543fd /sys-process
parentwww-apps/nextcloud-notify_push: drop 0.6.12 (diff)
downloadgentoo-f0506961c5d9a3edacdf0bfe041fc84753665e4f.tar.gz
gentoo-f0506961c5d9a3edacdf0bfe041fc84753665e4f.tar.bz2
gentoo-f0506961c5d9a3edacdf0bfe041fc84753665e4f.zip
sys-process/runit: fix errors & warnings with clang 18/gcc 15
20 patches from https://github.com/clan/runit/tree/ftbfs.v4 , which are divided into the following categories: 1. patch: 0001 purpose: helpful for development & debug: make full command line & result available in build.log, otherwise extra directives are required when debug 2. patch: 0002, 0003, 0004, 0005, 0006 purpose: required, build will failed if not apply 0005 & 0006 are warnings only for gcc < 14, errors if gcc >= 14 3. patch: 0007 purpose: patch from author w/ new feature provided, but don't change any "user-observable functionality" 4. patch: 0008 purpose: documentation change: w/ tiny (unlikely to cause problem) modification of source code 5. patch: 0009 - 0019 purpose: fix compilation warnings reported by gcc/clang, with -Wall, -Wextra 6. patch: 0020 purpose: usleep is obsoleted in POSIX.1-2001, handled this in compile time by feature test macro, replace w/ nanosleep if available Closes: https://bugs.gentoo.org/934410 Closes: https://bugs.gentoo.org/938262 Closes: https://bugs.gentoo.org/938282 Closes: https://github.com/clan/runit/issues/2 Signed-off-by: Z. Liu <zhixu.liu@gmail.com> Tested-by: Alex Efros <powerman-asdf@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/38425 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/runit/Manifest1
-rw-r--r--sys-process/runit/metadata.xml12
-rw-r--r--sys-process/runit/runit-2.1.2-r5.ebuild (renamed from sys-process/runit/runit-2.1.2-r4.ebuild)16
3 files changed, 27 insertions, 2 deletions
diff --git a/sys-process/runit/Manifest b/sys-process/runit/Manifest
index 8331848d7bf9..86dd43dacbcb 100644
--- a/sys-process/runit/Manifest
+++ b/sys-process/runit/Manifest
@@ -1 +1,2 @@
+DIST runit-2.1.2-patches-20240905.tar.xz 20104 BLAKE2B ebdc123ea722f223eec3ad5d63a4c3e7c4ef771592796f2d5624f4308c1d08eede7d4fa0c2a9fdd23dbf74be6135c69bae495d89cf582678b9308b1d146ef883 SHA512 15c5acd865ecc7f6c3b9b1fc94dc00bc44ceefd1c0ca6b53963d94338712cd716ad961826cccd065029ee67464dc288428952004ffcec3a1a97a058696f4f233
DIST runit-2.1.2.tar.gz 110916 BLAKE2B 101e514aeed282685ebe636f401ca6f94d157281d08a3ac487340aebe945b82d2ee01d41e9917446f4ebd7b27fe9fd18ba4ad55739ab1b62a0e59e1c438b55e9 SHA512 a18773ebf1aa22305dd89ed67363165b9fcf86c192b2be4e268d08005dd82d51265160c637abe072f2f2e378c4b315a75bd3d3e602c3e75bdd451a3b0190f8cf
diff --git a/sys-process/runit/metadata.xml b/sys-process/runit/metadata.xml
index 115e9d64a669..73e765e89483 100644
--- a/sys-process/runit/metadata.xml
+++ b/sys-process/runit/metadata.xml
@@ -1,5 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>zhixu.liu@gmail.com</email>
+ <name>Z. Liu</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">clan/runit</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/sys-process/runit/runit-2.1.2-r4.ebuild b/sys-process/runit/runit-2.1.2-r5.ebuild
index 2254657370c9..c64c0578d5e9 100644
--- a/sys-process/runit/runit-2.1.2-r4.ebuild
+++ b/sys-process/runit/runit-2.1.2-r5.ebuild
@@ -7,7 +7,11 @@ inherit toolchain-funcs flag-o-matic
DESCRIPTION="A UNIX init scheme with service supervision"
HOMEPAGE="https://smarden.org/runit/"
-SRC_URI="https://smarden.org/runit/${P}.tar.gz"
+PATCH_VER=20240905
+SRC_URI="
+ https://smarden.org/runit/${P}.tar.gz
+ https://github.com/clan/runit/releases/download/${PV}-r5/${P}-patches-${PATCH_VER}.tar.xz
+"
S=${WORKDIR}/admin/${P}/src
LICENSE="BSD"
@@ -17,8 +21,18 @@ IUSE="static"
RDEPEND="sys-apps/openrc"
+src_unpack() {
+ unpack ${P}.tar.gz
+ unpack ${P}-patches-${PATCH_VER}.tar.xz
+}
+
src_prepare() {
default
+ cd "${S}"/..
+ eapply -p3 "${WORKDIR}"/patches
+
+ cd "${S}"
+
# We either build everything or nothing static
sed -i -e 's:-static: :' Makefile || die