summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-02-20 14:28:12 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-02-20 14:29:00 +0000
commit72e05a0caa5d4fd43e67d0ac2dcd33f21aa5ba9e (patch)
tree6bba4ff1c15f9d3e03ef77c7777e22db02e6d7c1 /www-apache/mod_caucho/mod_caucho-4.0.26.ebuild
parentwww-apache/mod_caucho: Version bump to 4.0.47 (diff)
downloadgentoo-72e05a0caa5d4fd43e67d0ac2dcd33f21aa5ba9e.tar.gz
gentoo-72e05a0caa5d4fd43e67d0ac2dcd33f21aa5ba9e.tar.bz2
gentoo-72e05a0caa5d4fd43e67d0ac2dcd33f21aa5ba9e.zip
www-apache/mod_caucho: Remove old
This drops the only stable version but there are no revdeps and we need to clear this for the removal of Java 6. I recommend not marking it stable again until someone has done more than just build it. I don't use Resin or Apache and I'm not entirely confident that it would work. Package-Manager: portage-2.2.27
Diffstat (limited to 'www-apache/mod_caucho/mod_caucho-4.0.26.ebuild')
-rw-r--r--www-apache/mod_caucho/mod_caucho-4.0.26.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/www-apache/mod_caucho/mod_caucho-4.0.26.ebuild b/www-apache/mod_caucho/mod_caucho-4.0.26.ebuild
deleted file mode 100644
index aa80f16a34bf..000000000000
--- a/www-apache/mod_caucho/mod_caucho-4.0.26.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-
-inherit eutils apache-module autotools
-
-DESCRIPTION="mod_caucho connects Resin and Apache2"
-HOMEPAGE="http://www.caucho.com/"
-SRC_URI="http://www.caucho.com/download/resin-${PV}-src.zip
- mirror://gentoo/resin-gentoo-patches-${PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-IUSE=""
-
-DEPEND="app-arch/unzip
- ~virtual/jre-1.6.0"
-RDEPEND="~virtual/jre-1.6.0"
-
-S="${WORKDIR}/resin-${PV}"
-
-# See apache-module.eclass for more information.
-APACHE2_MOD_CONF="88_${PN}"
-APACHE2_MOD_DEFINE="CAUCHO"
-APACHE2_MOD_FILE="${S}/modules/c/src/apache2/.libs/${PN}.so"
-
-need_apache2_2
-
-src_prepare() {
- for i in "${WORKDIR}"/${PV}/mod_caucho-*; do
- epatch "${i}"
- done
-
- mkdir m4
- eautoreconf
- chmod 755 ./configure
-}
-
-src_configure() {
- econf --with-apxs=${APXS} --with-java-home=/usr || die "econf failed"
-}
-
-src_compile() {
- emake -C "${S}/modules/c/src/apache2/" || die "emake failed"
-}