summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-11-23 00:22:09 -0500
committerCraig Andrews <candrews@gentoo.org>2024-11-23 00:23:04 -0500
commitcbc0a5faf7bdb77cb024830119bd135ff42b2715 (patch)
tree4f1a854ebb986194f87a5fa3f74ca657b88e12af /www-apache
parentsys-apps/portage: Stabilize 3.0.66.1-r1 hppa, #942453 (diff)
downloadgentoo-cbc0a5faf7bdb77cb024830119bd135ff42b2715.tar.gz
gentoo-cbc0a5faf7bdb77cb024830119bd135ff42b2715.tar.bz2
gentoo-cbc0a5faf7bdb77cb024830119bd135ff42b2715.zip
www-apache/mod_authz_unixgroup: add 1.2.0
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_authz_unixgroup/Manifest1
-rw-r--r--www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.2.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/www-apache/mod_authz_unixgroup/Manifest b/www-apache/mod_authz_unixgroup/Manifest
index 286d71e1270e..0b42672ea3db 100644
--- a/www-apache/mod_authz_unixgroup/Manifest
+++ b/www-apache/mod_authz_unixgroup/Manifest
@@ -1 +1,2 @@
DIST mod_authz_unixgroup-1.1.0.tar.gz 10085 BLAKE2B d7948cf046d58bcf27dfd4310a69ea61395d75f67c782fdbeb3f96015b7df8abebb7c59a244efe37a20e42ed72b501cd757346812144cd66a1cae8dabbd62a42 SHA512 83c767b2eb903964e688658bc4ae4384afd14c99f714c9aafb8c5bdddc855511e0b81f3499411b401865e42028b587dbba4ea2eb5123fe32ac91899327d6bbb8
+DIST mod_authz_unixgroup-1.2.0.tar.gz 13442 BLAKE2B 8cd00db549834ef252ec48b54b2dc442a9c38ded3f34e3bb75b49e88232ab88ffbcec2481971c91629932e602729ca431d8084a92e4df17fee3742387d8b7f68 SHA512 fd74e1510ffa4ca273d9e97760cdda846ce7c7debbdfa09ba8b90f8d7dc0720d0fb128261680b48e6fba63ca273d98e0bcaadeeca9276e06809b51d4ab6e8c61
diff --git a/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.2.0.ebuild b/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.2.0.ebuild
new file mode 100644
index 000000000000..0f81e7971ee7
--- /dev/null
+++ b/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit apache-module
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/phokz/mod-auth-external.git"
+ inherit git-r3
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/phokz/mod-auth-external/archive/${P}.tar.gz"
+ KEYWORDS="amd64"
+ S="${WORKDIR}/mod-auth-external-${P}"
+fi
+
+DESCRIPTION="An Apache2 authorization DSO using unix groups"
+HOMEPAGE="https://github.com/phokz/mod-auth-external"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+need_apache2_4
+
+DOCFILES="CHANGES INSTALL README"
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="AUTHZ_UNIXGROUP"
+
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}