summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/eyeos
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/eyeos')
-rw-r--r--www-apps/eyeos/Manifest1
-rw-r--r--www-apps/eyeos/eyeos-2.5.ebuild47
-rw-r--r--www-apps/eyeos/metadata.xml12
3 files changed, 60 insertions, 0 deletions
diff --git a/www-apps/eyeos/Manifest b/www-apps/eyeos/Manifest
new file mode 100644
index 000000000000..227ff19c3966
--- /dev/null
+++ b/www-apps/eyeos/Manifest
@@ -0,0 +1 @@
+DIST eyeos-2.5.tar.gz 27820727 SHA256 d7ae68977e8cfd2f012f0541e840a6cc51a7a768b5ab6cc6938cc70fdc400f98
diff --git a/www-apps/eyeos/eyeos-2.5.ebuild b/www-apps/eyeos/eyeos-2.5.ebuild
new file mode 100644
index 000000000000..5afe3686c815
--- /dev/null
+++ b/www-apps/eyeos/eyeos-2.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit webapp eutils
+
+DESCRIPTION="AJAX web-based desktop environment"
+HOMEPAGE="http://www.eyeos.org"
+SRC_URI="mirror://sourceforge/eyeos/eyeos2/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php[curl,crypt,gd,json,mysql,mysqli,pdo,sharedmem,sqlite]
+ virtual/httpd-php"
+
+S=${WORKDIR}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Placeholder for first install
+ touch "${ED}/${MY_HTDOCSDIR}"/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/settings.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/settings.php
+
+ # Ugly, but eyeos needs write access in too many places
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/eyeos/system
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/eyeos/tmp
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/eyeos/users
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "To finish your install/upgrade, point your browser to the eyeOS installer at:"
+ elog " http://${VHOST_HOSTNAME}/${PN}/install/"
+ elog "Specific extensions may require additional packages (available or not in"
+ elog "portage), check the installer output"
+ webapp_pkg_postinst
+}
diff --git a/www-apps/eyeos/metadata.xml b/www-apps/eyeos/metadata.xml
new file mode 100644
index 000000000000..03b74a95ece4
--- /dev/null
+++ b/www-apps/eyeos/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <longdescription>eyeOS is an open source web desktop following the cloud computing concept, written in mainly PHP and XML. It acts as a platform for web applications written using the eyeOS Toolkit. It includes a Desktop environment with more than 60 applications and sys utils</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">eyeos</remote-id>
+ </upstream>
+</pkgmetadata>