summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-01-19 22:43:47 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-01-19 22:43:47 +0100
commit3e6985dec986cf54aec083d638ac7f4f49bb47dc (patch)
treeafa6a266115649a2bfd39b0d99ef8e6c67b3b9fc /www-apps/jekyll-paginate
parentwww-apps/jekyll-gist: Remove ruby19 target (diff)
downloadgentoo-3e6985dec986cf54aec083d638ac7f4f49bb47dc.tar.gz
gentoo-3e6985dec986cf54aec083d638ac7f4f49bb47dc.tar.bz2
gentoo-3e6985dec986cf54aec083d638ac7f4f49bb47dc.zip
www-apps/jekyll-paginate: Update to use rspec3, remove ruby19 target
Package-Manager: portage-2.2.27
Diffstat (limited to 'www-apps/jekyll-paginate')
-rw-r--r--www-apps/jekyll-paginate/jekyll-paginate-1.1.0.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/www-apps/jekyll-paginate/jekyll-paginate-1.1.0.ebuild b/www-apps/jekyll-paginate/jekyll-paginate-1.1.0.ebuild
index 0da6b8f08ac5..ff25886336c4 100644
--- a/www-apps/jekyll-paginate/jekyll-paginate-1.1.0.ebuild
+++ b/www-apps/jekyll-paginate/jekyll-paginate-1.1.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby20 ruby21"
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -24,8 +24,4 @@ ruby_add_bdepend "test? ( >=www-apps/jekyll-2 )"
all_ruby_prepare() {
rm Rakefile || die
- sed -i -e "s/truthy/true/" -e "s/falsey/false/" spec/pager_spec.rb || die
- # Remove unkown options until Rspec3 is in tree
- sed -i -e "/expectations.include_chain_clauses_in_custom_matcher_descriptions/d"\
- -e "/verify_partial_doubles/d" -e "/disable_monkey_patching!/d" spec/spec_helper.rb || die
}