summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-11-25 16:54:25 -0500
committerAaron Bauman <bman@gentoo.org>2018-11-25 16:54:25 -0500
commit2537634a025115a2c6d4a5022f98a5abaf056535 (patch)
treee673e99ea894b8ba8b2a9b1935e700692f350945 /www-apps/jekyll-watch/jekyll-watch-2.1.2.ebuild
parentdev-ruby/em-websocket: new package. supports www-apps/jekyll bump (diff)
downloadgentoo-2537634a025115a2c6d4a5022f98a5abaf056535.tar.gz
gentoo-2537634a025115a2c6d4a5022f98a5abaf056535.tar.bz2
gentoo-2537634a025115a2c6d4a5022f98a5abaf056535.zip
www-apps/jekyll-watch: version bump
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'www-apps/jekyll-watch/jekyll-watch-2.1.2.ebuild')
-rw-r--r--www-apps/jekyll-watch/jekyll-watch-2.1.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/www-apps/jekyll-watch/jekyll-watch-2.1.2.ebuild b/www-apps/jekyll-watch/jekyll-watch-2.1.2.ebuild
new file mode 100644
index 000000000000..3468c5c4a5e8
--- /dev/null
+++ b/www-apps/jekyll-watch/jekyll-watch-2.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md History.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rebuild your Jekyll site when a file changes with the --watch switch"
+HOMEPAGE="https://github.com/jekyll/jekyll-watch"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/listen-3.0"
+ruby_add_bdepend "test? ( >=www-apps/jekyll-2 )"
+
+all_ruby_prepare() {
+ rm Rakefile || die
+}