summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2025-01-26 19:30:51 +0100
committerUlrich Müller <ulm@gentoo.org>2025-01-26 19:31:14 +0100
commitd1869f87fee0e3c63052e32421f7c0a25d979c18 (patch)
tree56f09ad43a479c093fa502e4129b2e0610aac006 /www-apps/nikola
parentsys-cluster/knem: drop 1.1.4 (diff)
downloadgentoo-d1869f87fee0e3c63052e32421f7c0a25d979c18.tar.gz
gentoo-d1869f87fee0e3c63052e32421f7c0a25d979c18.tar.bz2
gentoo-d1869f87fee0e3c63052e32421f7c0a25d979c18.zip
www-apps/nikola: add 8.3.1
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'www-apps/nikola')
-rw-r--r--www-apps/nikola/Manifest1
-rw-r--r--www-apps/nikola/nikola-8.3.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/www-apps/nikola/Manifest b/www-apps/nikola/Manifest
index f0ff44c43d7b..01f0b4ef29f6 100644
--- a/www-apps/nikola/Manifest
+++ b/www-apps/nikola/Manifest
@@ -1,2 +1,3 @@
DIST Nikola-8.2.4.tar.gz 5635965 BLAKE2B 94421a278718fd9ae9f8978854954f2120bab005d10a52294b120d619a67455417eed94bb9e99cc9d01eca4e1d3da210980caef1ad7ff4ca5d25299a39d8eb19 SHA512 2bcea53181a5371fc1ce7d6d96e5db1ae0ab7c4bc8fe8947ed0d5427e71a469b0f522f1e6f20a47e51a3325730a9646156a8a57bab127785f220c65eb9f891ea
DIST Nikola-8.3.0.tar.gz 4557992 BLAKE2B 67ab76c670fd00d992e6359bcaa11c59dfc904c78c935d1739e6ed7118e38c8f1c4590782a75e85c722f4fcb2c23efc032cb5d58d0c1587069b80920f3bd20fa SHA512 9b25eb90fa560b45e8cd0b03f24523859548353f2a4d2ac91b23b05bfb614d20456bb71f1aaa5702b6d6ab7980696aeb2f5ccc3c00ebc648cfcad49619481247
+DIST Nikola-8.3.1.tar.gz 4559433 BLAKE2B 32bffeaf5f490f6c7bdf48b1c3b1906e4fb9a94fb196ecba8f0c2f074489b05e57c4278ae6ec8a6d91838772d19ddb0444166e05caa4d0d3055bd388b9b8cc63 SHA512 cbf4e099e2e1ee22ab16c8a3d3984617097721cb24cf03cf9673fc89d051fa712a05cbbfb522f85d6808155a0fa8835b1630096691a33c25aee8cf24564df050
diff --git a/www-apps/nikola/nikola-8.3.1.ebuild b/www-apps/nikola/nikola-8.3.1.ebuild
new file mode 100644
index 000000000000..506e9eb20887
--- /dev/null
+++ b/www-apps/nikola/nikola-8.3.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10,11,12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit bash-completion-r1 distutils-r1 optfeature pypi
+
+DESCRIPTION="A static website and blog generator"
+HOMEPAGE="https://getnikola.com/"
+SRC_URI="$(pypi_sdist_url --no-normalize ${PN^} ${PV})"
+S="${WORKDIR}/${P^}"
+
+LICENSE="MIT Apache-2.0 CC0-1.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+RESTRICT="test" # needs coveralls
+
+BDEPEND=">=dev-python/docutils-0.13[${PYTHON_USEDEP}]" # needs rst2man to build manpage
+RDEPEND="${BDEPEND}
+ >=dev-python/babel-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.3[${PYTHON_USEDEP}]
+ >=dev-python/doit-0.32[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.3.5[${PYTHON_USEDEP}]
+ >=dev-python/mako-1.0[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/natsort-3.5.2[${PYTHON_USEDEP}]
+ >=dev-python/piexif-1.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
+ >=dev-python/pyrss2gen-1.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-67.2.0[${PYTHON_USEDEP}]
+ >=dev-python/unidecode-0.04.16[${PYTHON_USEDEP}]
+ >=dev-python/yapsy-1.11.223[${PYTHON_USEDEP}]
+ dev-python/pillow[jpeg,${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ nikola tabcompletion --shell=bash > ${PN}.bashcomp || die
+ nikola tabcompletion --shell=zsh > ${PN}.zshcomp || die
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # hackish way to remove docs that ended up in the wrong place
+ rm -r "${ED}/usr/share/doc/${PN}" || die
+
+ dodoc AUTHORS.txt CHANGES.txt README.rst docs/*.rst
+ gunzip "${ED}/usr/share/man/man1/${PN}.1.gz" || die
+
+ newbashcomp ${PN}.bashcomp ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zshcomp _${PN}
+}
+
+pkg_postinst() {
+ optfeature "chart generation" dev-python/pygal
+ optfeature "hyphenation support" dev-python/pyphen
+ optfeature "notebook compilation and LESS support" dev-python/ipython
+ optfeature "alternative templating engine to Mako" dev-python/jinja2
+ optfeature "built-in web server support" dev-python/aiohttp
+ optfeature "monitoring file system events" dev-python/watchdog
+ optfeature "extracting metadata from web media links" dev-python/micawber
+}