summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-07-11 19:32:15 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-07-11 19:32:56 +0300
commitcb2931c422089c0ddae6ad9ef0e8f046ff3067c4 (patch)
treee1913ec7f14dfab5d865d7aba32baff4b4046ad6 /www-apps
parentapp-arch/patool: add 2.3.0 (diff)
downloadgentoo-cb2931c422089c0ddae6ad9ef0e8f046ff3067c4.tar.gz
gentoo-cb2931c422089c0ddae6ad9ef0e8f046ff3067c4.tar.bz2
gentoo-cb2931c422089c0ddae6ad9ef0e8f046ff3067c4.zip
www-apps/nanoblogger: treeclean
Bug: https://bugs.gentoo.org/295842 Bug: https://bugs.gentoo.org/526340 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/nanoblogger/Manifest1
-rw-r--r--www-apps/nanoblogger/files/nb.bashcomp47
-rw-r--r--www-apps/nanoblogger/metadata.xml21
-rw-r--r--www-apps/nanoblogger/nanoblogger-3.5_rc1-r1.ebuild70
4 files changed, 0 insertions, 139 deletions
diff --git a/www-apps/nanoblogger/Manifest b/www-apps/nanoblogger/Manifest
deleted file mode 100644
index c7f74814e0d6..000000000000
--- a/www-apps/nanoblogger/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST nanoblogger-3.5-rc1.tar.gz 131833 BLAKE2B d5918e406d0b5c6d82b466b43ed84b413fc539651baa568eacbd70b47eae4b382a4f621c8195631b47ef2039d6a4e0b569596a6d601881b195b1db5f7098d90c SHA512 03a590b1bdf3adb9969e2ce6fda89ece99f33def9f46e1028d2c0724a86f47696c703a5a3bb3c4b1c34418b841702a15bae527cc94eba377ee2003203582de2f
diff --git a/www-apps/nanoblogger/files/nb.bashcomp b/www-apps/nanoblogger/files/nb.bashcomp
deleted file mode 100644
index 4e3c5606b1c0..000000000000
--- a/www-apps/nanoblogger/files/nb.bashcomp
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# nanoblogger completion
-# author: Aaron Walker <ka0ttic@gentoo.org>
-
-_nb()
-{
- local cur prev opts
- COMPREPLY=()
- cur="${COMP_WORDS[COMP_CWORD]}"
- prev="${COMP_WORDS[COMP_CWORD-1]}"
- opts="-a --add -b --blogdir -B --body -c --category --configure \
- --datadir -d --delete -D --desc -e --edit -f --blogconf -h --help \
- -l --list --makepage --manual -m --move -n --author -p --preview \
- -P --publish --template --templatedir -t --title -u --update \
- -v --verbose -V --version"
-
- if [[ "${cur}" == -* || ${COMP_CWORD} -eq 1 ]] ; then
- COMPREPLY=($(compgen -W "${opts}" -- ${cur}))
- return 0
- fi
-
- case "${prev}" in
- -b|--*dir)
- COMPREPLY=($(compgen -d -S '/' -- ${cur}))
- ;;
- -f|--blogconf|--template)
- COMPREPLY=($(compgen -f -- ${cur}))
- ;;
- -l|--list)
- COMPREPLY=($(compgen -W "all cat current max" -- ${cur}))
- ;;
- -u|--update)
- COMPREPLY=($(compgen -W "all current main max" -- ${cur}))
- ;;
- ?(-)-@(B|body|c|category|d|delete|D|desc|m|move|n|author|t|title))
- COMPREPLY=()
- ;;
- *)
- COMPREPLY=($(compgen -W "${opts/${prev}}" -- ${cur}))
- ;;
- esac
-}
-complete -F _nb nb
-
-# vim: set ft=sh :
diff --git a/www-apps/nanoblogger/metadata.xml b/www-apps/nanoblogger/metadata.xml
deleted file mode 100644
index 4da5e4e1c955..000000000000
--- a/www-apps/nanoblogger/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <stabilize-allarches/>
- <longdescription lang="en">
-Nanoblogger is a small weblog engine written in Bash for the command line. It
-uses common UNIX tools such as cat, grep, and sed. Features include: support
-for multiple weblogs, support for multiple categories, archiving by category,
-entry, and month, pagination, permanent links, RSS syndication (1.0 and 2.0),
-Atom syndication (0.3), templates and CSS style sheets for full control over
-appearance, placeholders for easy template manipulation, plugins for calendar,
-recent entries, weblog status, fortunes, etc, auto-formatting of HTML, support
-for relative and absolute links, per-weblog configuration, simple cache system
-for faster content generation, auto-detection of weblog by current directory, no
-database dependencies (uses flat-file), and mutliplatform portability.
- </longdescription>
- <upstream>
- <remote-id type="sourceforge">nanoblogger</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/www-apps/nanoblogger/nanoblogger-3.5_rc1-r1.ebuild b/www-apps/nanoblogger/nanoblogger-3.5_rc1-r1.ebuild
deleted file mode 100644
index 4116a3b95219..000000000000
--- a/www-apps/nanoblogger/nanoblogger-3.5_rc1-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit bash-completion-r1
-
-MY_P="${P/_/-}"
-DESCRIPTION="Small and simple weblog engine written in Bash for the command-line"
-HOMEPAGE="http://nanoblogger.sourceforge.net/"
-SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ppc x86"
-
-RDEPEND="app-shells/bash"
-
-S="${WORKDIR}/${MY_P}"
-
-HTML_DOCS=( docs/nanoblogger.html )
-
-src_prepare() {
- default
- sed -i \
- -e 's|^\(NB_BASE_DIR=\).*$|\1"/usr/share/nanoblogger"|' \
- -e 's|^\(NB_CFG_DIR=\).*$|\1"/etc"|' \
- -e "s|\$NB_BASE_DIR.*\(nano.*html\)|/usr/share/doc/${PF}/html/\1|" \
- nb || die "sed nb failed"
-}
-
-src_install() {
- dobin nb
- insinto /usr/share/nanoblogger
- doins -r default moods plugins lib lang docs welcome-to-nb.txt
- insinto /etc
- doins nb.conf
- einstalldocs
- dobashcomp "${FILESDIR}"/nb.bashcomp
-}
-
-pkg_postinst() {
- elog
- elog "Documentation for getting started with nanoblogger may be found at"
- elog "/usr/share/doc/${PF}/html/nanoblogger.html or by running 'nb --manual;."
- elog
- elog "To create and configure a new weblog, run the following as your user:"
- elog " nb -b /some/dir -a"
- elog "where /some/dir is a directory that DOES NOT exist."
- elog
- elog "To prevent having to specify your blog directory every time you use"
- elog "nanoblogger (with the -b switch), you can set a default value in your"
- elog "~/.nb.conf. For example:"
- elog ' BLOG_DIR="$HOME/public_html/blog"'
- elog
- elog "If you are upgrading nanoblogger from a previous version, follow"
- elog "these directions (as stated in the manual):"
- elog " 1. create a new weblog directory using nanoblogger (skip configuration):"
- elog " nb [-b blog_dir] -a"
- elog " 2. copy old data directry to new weblog:"
- elog " cp -r [old_blog_dir]/data [newblog_dir]"
- elog " 3. edit new blog.conf to your liking and rebuild weblog:"
- elog " nb [-b blog_dir] --configure -u all"
- elog
- elog "You also should remove your [newblog_dir]/data/cat_1.db and run:"
- elog " nb -u all"
- elog "after copying your old entries from [oldblog_dir]/data to"
- elog "[newblog_dir]/data."
- elog
-}