summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-11 20:02:04 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-11 20:04:16 +0200
commit52cb2020ea62f113f0cebf2fc4a5c5b6ca25f013 (patch)
treec45a57b801eebe89077cb4400aaf9d327997eadc /www-servers
parentsci-libs/libsigrok: Stabilize 0.5.2-r4 amd64, #934061 (diff)
downloadgentoo-52cb2020ea62f113f0cebf2fc4a5c5b6ca25f013.tar.gz
gentoo-52cb2020ea62f113f0cebf2fc4a5c5b6ca25f013.tar.bz2
gentoo-52cb2020ea62f113f0cebf2fc4a5c5b6ca25f013.zip
www-servers/pshs: Bump to 0.4.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pshs/Manifest1
-rw-r--r--www-servers/pshs/pshs-0.4.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/www-servers/pshs/Manifest b/www-servers/pshs/Manifest
index c2a944a38aa7..02352830014b 100644
--- a/www-servers/pshs/Manifest
+++ b/www-servers/pshs/Manifest
@@ -1,2 +1,3 @@
DIST pshs-0.4.1.tar.gz 11758 BLAKE2B b3f9422c8ebd47d3de9993b93ea0438232f3ba037d7433b08875a131f449fab880a205bb62616a057328b7d6fe9c00277fbb2e886a1494d2234ab684b0a1e90f SHA512 7ecd0e5019e9778b5f2eff31b8e2f481972cf6da66e4493cff850aa1ec13a4df46e46782799ab25cecd1cc36122f797c6ae0ac2863ea604477784a79191a62d6
DIST pshs-0.4.2.gh.tar.gz 11908 BLAKE2B 34afa32fe8cdb9212bcc22ec8b33e149b703cb2c5d12d4655732ce6e1400850a42770f2a5855c826bbcc1fb31e6f891a7e06fbf34bc8695933a39c8fe0b3f871 SHA512 0ec5c030fcc8b2073a3c524a5611e9861416523c73639aa3859d6c4bc1e69e2452c9e883f535129313db724b6bd48f00592d94321405450dbd9f4a9fdc3edb5b
+DIST pshs-0.4.3.gh.tar.gz 12196 BLAKE2B 428b0a49dbbf53efdbfc0b8954035dbd1aea17e13c73a15c2f1e30625f898193beaa641e8dc4d65fac8dc14411a1840475d04ee399814ccacf63634fdad82979 SHA512 1a137f4f4f4f04afb8433843fbf3e9942a97781c3d74d198788ef9d696067984260423601983491c506b95b704255d77ce99b9ffa9def1020073abf6218bedbe
diff --git a/www-servers/pshs/pshs-0.4.3.ebuild b/www-servers/pshs/pshs-0.4.3.ebuild
new file mode 100644
index 000000000000..8fbc89f3a612
--- /dev/null
+++ b/www-servers/pshs/pshs-0.4.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Pretty small HTTP server -- a command-line tool to share files"
+HOMEPAGE="https://github.com/projg2/pshs/"
+SRC_URI="
+ https://github.com/projg2/pshs/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+magic qrcode ssl upnp"
+
+DEPEND="
+ >=dev-libs/libevent-2.1:=
+ magic? ( sys-apps/file:= )
+ qrcode? ( media-gfx/qrencode:= )
+ ssl? (
+ >=dev-libs/libevent-2.1:=[ssl]
+ dev-libs/openssl:0=
+ )
+ upnp? ( net-libs/miniupnpc:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature magic libmagic)
+ $(meson_feature qrcode qrencode)
+ $(meson_feature ssl)
+ $(meson_feature upnp)
+ )
+
+ meson_src_configure
+}