summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-09 16:34:55 +0000
committerSam James <sam@gentoo.org>2023-12-09 18:06:00 +0000
commit734485684fdf87e64b35402e54c3b51657d62689 (patch)
tree0d958d88fab400135a155b4de305ad59f2cb726c /x11-apps
parentdev-python/sympy: fix modern C issue (diff)
downloadgentoo-734485684fdf87e64b35402e54c3b51657d62689.tar.gz
gentoo-734485684fdf87e64b35402e54c3b51657d62689.tar.bz2
gentoo-734485684fdf87e64b35402e54c3b51657d62689.zip
x11-apps/xlsfonts: fix modern C issue
Closes: https://bugs.gentoo.org/919204 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xlsfonts/files/xlsfonts-1.0.7-c99.patch66
-rw-r--r--x11-apps/xlsfonts/xlsfonts-1.0.7-r1.ebuild19
2 files changed, 85 insertions, 0 deletions
diff --git a/x11-apps/xlsfonts/files/xlsfonts-1.0.7-c99.patch b/x11-apps/xlsfonts/files/xlsfonts-1.0.7-c99.patch
new file mode 100644
index 000000000000..55b767bb6a26
--- /dev/null
+++ b/x11-apps/xlsfonts/files/xlsfonts-1.0.7-c99.patch
@@ -0,0 +1,66 @@
+https://bugs.gentoo.org/919204
+https://gitlab.freedesktop.org/xorg/app/xlsfonts/-/issues/1
+https://gitlab.freedesktop.org/xorg/app/xlsfonts/-/merge_requests/6
+
+From c92bb3e8243773535cecc4f347437a59d01dbfef Mon Sep 17 00:00:00 2001
+From: Alan Coopersmith <alan.coopersmith@oracle.com>
+Date: Tue, 5 Dec 2023 15:41:28 -0800
+Subject: [PATCH 2/2] Fix -Wincompatible-pointer-types warning from gcc (issue
+ #1)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+xlsfonts.c: In function ‘get_list’:
+xlsfonts.c:204:23: warning: assignment to ‘char **’ from incompatible
+ pointer type ‘const char **’ [-Wincompatible-pointer-types]
+ 204 | fonts = &pattern;
+ | ^
+
+Closes: #1
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+---
+ xlsfonts.c | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/xlsfonts.c b/xlsfonts.c
+index b834637..39aba13 100644
+--- a/xlsfonts.c
++++ b/xlsfonts.c
+@@ -56,6 +56,7 @@ static int long_list = L_SHORT;
+ static int nnames = N_START;
+ static int font_cnt = 0;
+ static int min_max;
++static char wild_string[] = "*";
+
+ typedef struct {
+ char *name;
+@@ -65,7 +66,7 @@ typedef struct {
+ static FontList *font_list = NULL;
+
+ /* Local prototypes */
+-static void get_list(const char *pattern);
++static void get_list(char *pattern);
+ static int compare(const void *arg1, const void *arg2);
+ static void show_fonts(void);
+ static void copy_number(char **pp1, char **pp2, int n1, int n2);
+@@ -180,7 +181,7 @@ main(int argc, char **argv)
+ }
+
+ if (argcnt == 0)
+- get_list("*");
++ get_list(wild_string);
+
+ show_fonts();
+
+@@ -189,7 +190,7 @@ main(int argc, char **argv)
+ }
+
+ static void
+-get_list(const char *pattern)
++get_list(char *pattern)
+ {
+ int available = nnames + 1, i;
+ char **fonts;
+--
+GitLab
diff --git a/x11-apps/xlsfonts/xlsfonts-1.0.7-r1.ebuild b/x11-apps/xlsfonts/xlsfonts-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..8964da7f9ca4
--- /dev/null
+++ b/x11-apps/xlsfonts/xlsfonts-1.0.7-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org xlsfonts application"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.7-c99.patch
+)