summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-13 10:25:43 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-20 18:52:24 +0300
commit0d75b67d3dc35f237af79d93b71a84bdbe61f4d3 (patch)
treefebc3181f92feb7fbcfb8b0ca0402fffd3ebc21a /x11-base
parentdev-python/pikepdf: add 5.5.0 (diff)
downloadgentoo-0d75b67d3dc35f237af79d93b71a84bdbe61f4d3.tar.gz
gentoo-0d75b67d3dc35f237af79d93b71a84bdbe61f4d3.tar.bz2
gentoo-0d75b67d3dc35f237af79d93b71a84bdbe61f4d3.zip
x11-base/xorg-proto: use python_has_version
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-proto/xorg-proto-2022.1.ebuild5
-rw-r--r--x11-base/xorg-proto/xorg-proto-2022.2.ebuild5
-rw-r--r--x11-base/xorg-proto/xorg-proto-9999.ebuild4
3 files changed, 6 insertions, 8 deletions
diff --git a/x11-base/xorg-proto/xorg-proto-2022.1.ebuild b/x11-base/xorg-proto/xorg-proto-2022.1.ebuild
index cdf53c6454cf..cc92a19d2a28 100644
--- a/x11-base/xorg-proto/xorg-proto-2022.1.ebuild
+++ b/x11-base/xorg-proto/xorg-proto-2022.1.ebuild
@@ -30,17 +30,16 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="
+BDEPEND="
test? (
$(python_gen_any_dep '
dev-python/python-libevdev[${PYTHON_USEDEP}]
')
)
"
-RDEPEND=""
python_check_deps() {
- has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/python-libevdev[${PYTHON_USEDEP}]"
}
pkg_setup() {
diff --git a/x11-base/xorg-proto/xorg-proto-2022.2.ebuild b/x11-base/xorg-proto/xorg-proto-2022.2.ebuild
index ccbe4831235d..0264a3a486c4 100644
--- a/x11-base/xorg-proto/xorg-proto-2022.2.ebuild
+++ b/x11-base/xorg-proto/xorg-proto-2022.2.ebuild
@@ -30,17 +30,16 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="
+BDEPEND="
test? (
$(python_gen_any_dep '
dev-python/python-libevdev[${PYTHON_USEDEP}]
')
)
"
-RDEPEND=""
python_check_deps() {
- has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/python-libevdev[${PYTHON_USEDEP}]"
}
pkg_setup() {
diff --git a/x11-base/xorg-proto/xorg-proto-9999.ebuild b/x11-base/xorg-proto/xorg-proto-9999.ebuild
index ccbe4831235d..91976a0a2225 100644
--- a/x11-base/xorg-proto/xorg-proto-9999.ebuild
+++ b/x11-base/xorg-proto/xorg-proto-9999.ebuild
@@ -30,7 +30,7 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="
+BDEPEND="
test? (
$(python_gen_any_dep '
dev-python/python-libevdev[${PYTHON_USEDEP}]
@@ -40,7 +40,7 @@ DEPEND="
RDEPEND=""
python_check_deps() {
- has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/python-libevdev[${PYTHON_USEDEP}]"
}
pkg_setup() {