summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-04-15 11:01:31 -0400
committerMatt Turner <mattst88@gentoo.org>2024-04-15 11:32:46 -0400
commit24ba76702f85e062cf98a67174ff2bc2e3d187c2 (patch)
tree76de586d5ee333afc5c57a0cd8b4a2227b11c60d /x11-base
parentmedia-gfx/scour: Fix distfile suffix (diff)
downloadgentoo-24ba76702f85e062cf98a67174ff2bc2e3d187c2.tar.gz
gentoo-24ba76702f85e062cf98a67174ff2bc2e3d187c2.tar.bz2
gentoo-24ba76702f85e062cf98a67174ff2bc2e3d187c2.zip
x11-base/xcb-proto: Version bump to 1.17.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xcb-proto/Manifest1
-rw-r--r--x11-base/xcb-proto/xcb-proto-1.17.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/x11-base/xcb-proto/Manifest b/x11-base/xcb-proto/Manifest
index 747414d33e52..a85212c9bc77 100644
--- a/x11-base/xcb-proto/Manifest
+++ b/x11-base/xcb-proto/Manifest
@@ -1 +1,2 @@
DIST xcb-proto-1.16.0.tar.xz 151612 BLAKE2B 1c59ae4c71e697bd4f0298f6e0ea5235fc47baa9cf584e079258f1da8be538d1b67dc45f1325d82495247d0f8020d0244ca334de3794b410a1feaceabd6b285e SHA512 54906f379a7aa2cbbfbbe54764c02dbf522ca8f6c54e07d4faae471aac3aee25d0359be38c808c8da887de228aed745582a78b2f56714b023bca8f3513b24972
+DIST xcb-proto-1.17.0.tar.xz 151748 BLAKE2B 0f46d040062fca4f6b598bdb7ab7a254b9aefce198812af82fd2112e06e88277e3c9e0a3bab161930b56688e71e1848bb859d4f33588f9496fe7399f9758b9a7 SHA512 34c3795e5a48a66d89b72ee1777fb0bede489d5ec07018e6c9ef3c13bdd60b0358fc2c04a1f0ed0acb5b681aeeb92033db579036e4f5edd967fe56714c03acdf
diff --git a/x11-base/xcb-proto/xcb-proto-1.17.0.ebuild b/x11-base/xcb-proto/xcb-proto-1.17.0.ebuild
new file mode 100644
index 000000000000..a7af99861180
--- /dev/null
+++ b/x11-base/xcb-proto/xcb-proto-1.17.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+XORG_TARBALL_SUFFIX="xz"
+XORG_MODULE=proto/
+
+inherit python-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/proto/xcbproto"
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/xcbproto.git"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# DEPEND=""
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2
+"
+
+ECONF_SOURCE="${S}"
+
+src_configure() {
+ # Don't use Python to find sitedir here.
+ PYTHON=true default
+}
+
+src_compile() {
+ :
+}
+
+xcbgen_install() {
+ # Use eclass to find sitedir instead.
+ emake -C xcbgen install DESTDIR="${D}" pythondir="$(python_get_sitedir)"
+ python_optimize
+}
+
+src_install() {
+ # Restrict SUBDIRS to prevent xcbgen with empty sitedir.
+ emake install DESTDIR="${D}" SUBDIRS=src
+ python_foreach_impl xcbgen_install
+}