summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-27 02:00:07 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-27 06:11:13 -0500
commit6e558b55644cc9cc496b3f9859ec3c2b3a619471 (patch)
tree6ceae6368dea4198f1e9550a9e30b22bc41005ba /x11-drivers/nvidia-drivers/nvidia-drivers-470.161.03.ebuild
parentx11-drivers/nvidia-drivers: use -ffat-lto-objects for libXNVCtrl.a (diff)
downloadgentoo-6e558b55644cc9cc496b3f9859ec3c2b3a619471.tar.gz
gentoo-6e558b55644cc9cc496b3f9859ec3c2b3a619471.tar.bz2
gentoo-6e558b55644cc9cc496b3f9859ec3c2b3a619471.zip
x11-drivers/nvidia-drivers: attempt fatal GCC_PLUGINS warning
Seen a user miss the warning and wondering why it didn't just die for attention. Was formerly worried it may die when it shouldn't, but the exact string check makes that unlikely. Fairly rare that this is an issue nowadays though, GCC_PLUGINS are typically not actually in-use and so errors don't happen (check won't trigger then either). Test isn't perfect, doesn't consider some configurations (just informational, so not very important), but still fix with -native-symlinks while here. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-drivers/nvidia-drivers/nvidia-drivers-470.161.03.ebuild')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-470.161.03.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-470.161.03.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-470.161.03.ebuild
index 3d9b38865127..2f90ba9654fe 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-470.161.03.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-470.161.03.ebuild
@@ -257,12 +257,13 @@ src_compile() {
echo "obj-m += test.o" > "${T}"/plugin-test/Kbuild || die
:> "${T}"/plugin-test/test.c || die
if [[ $(LC_ALL=C make -C "${KV_OUT_DIR}" ARCH="$(tc-arch-kernel)" \
- HOSTCC="$(tc-getBUILD_CC)" M="${T}"/plugin-test 2>&1) \
+ HOSTCC="$(tc-getBUILD_CC)" CC="${CC}" M="${T}"/plugin-test 2>&1) \
=~ "error: incompatible gcc/plugin version" ]]
then
- ewarn "Warning: detected kernel was built with different gcc/plugin versions,"
- ewarn "you may need to 'make clean' and rebuild your kernel with the current"
- ewarn "gcc version (or re-emerge for distribution kernels, including kernel-bin)."
+ eerror "Detected kernel was built with a different gcc/plugin version,"
+ eerror "Please 'make clean' and rebuild your kernel with the current"
+ eerror "gcc (or re-emerge for distribution kernels, including kernel-bin)."
+ die "kernel ${KV_FULL} needs to be rebuilt"
fi
fi