summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-10-17 22:37:27 -0400
committerMatt Turner <mattst88@gentoo.org>2024-10-17 22:40:14 -0400
commit9efcabeba02c58243810628779ea1224e02fd06c (patch)
tree775e810bd14d0fffbf99c09ccc6de6c7e3796d82 /x11-libs/xtrans
parentx11-drivers/xf86-video-r128: Version bump to 6.13.0 (diff)
downloadgentoo-9efcabeba02c58243810628779ea1224e02fd06c.tar.gz
gentoo-9efcabeba02c58243810628779ea1224e02fd06c.tar.bz2
gentoo-9efcabeba02c58243810628779ea1224e02fd06c.zip
x11-libs/xtrans: Version bump to 1.5.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/xtrans')
-rw-r--r--x11-libs/xtrans/Manifest1
-rw-r--r--x11-libs/xtrans/xtrans-1.5.1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/x11-libs/xtrans/Manifest b/x11-libs/xtrans/Manifest
index 043c085ac8c4..aad5ee4d6caa 100644
--- a/x11-libs/xtrans/Manifest
+++ b/x11-libs/xtrans/Manifest
@@ -1 +1,2 @@
DIST xtrans-1.5.0.tar.xz 170388 BLAKE2B a07dc501a36f4a6d7d9c407c36c5fcaa9555eeec3066d91fa8531118ac04bc55a1fbdce6370782aa8a18e1f26b14e3ad644e1e98ae3a353234e3ecae71fe065b SHA512 e8091f11d4ad2b14e01de3eac56bdf2267ea26687ce66e3056374d0d02e049480c0b27c482f8828a0efd086f1e4c485108ca4dce3f83d66c1896effa3b38b228
+DIST xtrans-1.5.1.tar.xz 175624 BLAKE2B 5ab6ffdc0028da16b4373f824c9bfc51db9bb90bc593c101b2647496846687fd020423e4eb204e8b261fa39123f5a57338b9257b13b7abb92e8d1a49cd3c3345 SHA512 1a4bf3495ba401711b632972acf26bb82c2e8fd917a868ed21e510a1bb1ec57c145496baddb44de76e00c2d03dbf9e8592099623da4c065de3a7c5a804e87c1e
diff --git a/x11-libs/xtrans/xtrans-1.5.1.ebuild b/x11-libs/xtrans/xtrans-1.5.1.ebuild
new file mode 100644
index 000000000000..6555ce70c0bc
--- /dev/null
+++ b/x11-libs/xtrans/xtrans-1.5.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_PACKAGE_NAME="lib${PN}"
+# this package just installs some .c and .h files, no libraries
+XORG_DOC=doc
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org xtrans library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}