summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2020-08-15 15:53:44 -0400
committerMatt Turner <mattst88@gentoo.org>2020-08-16 17:08:56 -0700
commit0b794fa254a116008dc76a9a2a6188433988a814 (patch)
tree5dd0fd9d13b4ca934b2d4b7e3db92735aed84991 /x11-libs
parentxorg-3.eclass: set XORG_MODULE for xcb-util packages (diff)
downloadgentoo-0b794fa254a116008dc76a9a2a6188433988a814.tar.gz
gentoo-0b794fa254a116008dc76a9a2a6188433988a814.tar.bz2
gentoo-0b794fa254a116008dc76a9a2a6188433988a814.zip
x11-libs/xcb-util: EAPI 7
Drop the SRC_URI definitions since the eclass automates it. Drop the git eclass variables since there is no live ebuild. Drop the doc USE flag since it has no effect. Drop the test flag since there are no tests. Drop the gperf dependency since it was removed in 2012. Add xorg-proto as a build-time dependency. Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xcb-util/xcb-util-0.4.0-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-libs/xcb-util/xcb-util-0.4.0-r2.ebuild b/x11-libs/xcb-util/xcb-util-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..8a42590c5db8
--- /dev/null
+++ b/x11-libs/xcb-util/xcb-util-0.4.0-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb-util"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1:=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PDEPEND="
+ >=x11-libs/xcb-util-cursor-0.1.1:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-image-${PV}:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-keysyms-${PV}:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-renderutil-0.3.9:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-wm-${PV}:=[${MULTILIB_USEDEP}]
+"