summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-23 18:09:54 -0300
committerPacho Ramos <pacho@gentoo.org>2023-10-08 13:51:12 +0200
commit00bdc34d243383351a7c6a4f9d5e61e5c561dad8 (patch)
treedb9952e386ae24173e9bdf28d4da548d11a95c58 /x11-misc/alacarte/alacarte-3.50.0.ebuild
parentx11-terms/gnome-terminal: Version bump to 3.50.0 (diff)
downloadgentoo-00bdc34d243383351a7c6a4f9d5e61e5c561dad8.tar.gz
gentoo-00bdc34d243383351a7c6a4f9d5e61e5c561dad8.tar.bz2
gentoo-00bdc34d243383351a7c6a4f9d5e61e5c561dad8.zip
x11-misc/alacarte: Version bump to 3.50.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33018 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-misc/alacarte/alacarte-3.50.0.ebuild')
-rw-r--r--x11-misc/alacarte/alacarte-3.50.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/alacarte/alacarte-3.50.0.ebuild b/x11-misc/alacarte/alacarte-3.50.0.ebuild
new file mode 100644
index 000000000000..e37452553a19
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-3.50.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/alacarte"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ >=gnome-base/gnome-menus-3.5.3:3[introspection]
+"
+RDEPEND="${DEPEND}
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}