summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/icewmcp/icewmcp-3.2-r4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/icewmcp/icewmcp-3.2-r4.ebuild')
-rw-r--r--x11-misc/icewmcp/icewmcp-3.2-r4.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/x11-misc/icewmcp/icewmcp-3.2-r4.ebuild b/x11-misc/icewmcp/icewmcp-3.2-r4.ebuild
new file mode 100644
index 000000000000..7c97bf317f7a
--- /dev/null
+++ b/x11-misc/icewmcp/icewmcp-3.2-r4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit multilib python-single-r1
+
+MY_PN=IceWMControlPanel
+DESCRIPTION="A complete control panel for IceWM using gtk & python"
+HOMEPAGE="http://icesoundmanager.sourceforge.net/index.php"
+SRC_URI="mirror://sourceforge/icesoundmanager/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="
+ dev-python/pygtk:2
+ x11-libs/gtk+:2
+ x11-wm/icewm
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/INSTALL-IceWMCP
+
+src_prepare() {
+ rm -rf licenses
+ mv doc .. || die
+}
+
+src_install() {
+ local dest="/usr/$(get_libdir)/${P}"
+ insinto ${dest}
+ doins -r *
+
+ local w wraps=(
+ "IceWMCP.py IceWMCP"
+ "IceWMCPKeyboard.py IceWMCP-Keyboard"
+ "IceWMCPMouse.py IceWMCP-Mouse"
+ "pyspool.py IceWMCP-PySpool"
+ "IceWMCPWallpaper.py IceWMCP-Wallpaper"
+ "IceWMCPWinOptions.py IceWMCP-WinOptions"
+ "phrozenclock.py PhrozenClock"
+ "icesound.py IceSoundManager"
+ "IceWMCP_GtkPCCard.py GtkPCCard"
+ "IceMe.py iceme"
+ "icepref.py icepref"
+ "icepref_td.py icepref_td"
+ "IceWMCPGtkIconSelection.py IceWMCP-Icons"
+ "IceWMCPEnergyStar.py IceWMCP-EnergyStar"
+ )
+ for w in "${wraps[@]}" ; do
+ set -- ${w}
+ printf '#!/bin/sh\nexec %s %s/%s\n' "${EPYTHON}" "${dest}" "$1" > "${T}"/$2
+ dobin "${T}"/$2 || die
+ done
+
+ dodoc ../doc/*.txt
+ dohtml ../doc/*.html
+ python_optimize "${D}/${dest}"
+}