summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/virtualgl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/virtualgl')
-rw-r--r--x11-misc/virtualgl/Manifest2
-rw-r--r--x11-misc/virtualgl/files/vgl-helper.sh39
-rw-r--r--x11-misc/virtualgl/files/vgl.confd-r127
-rw-r--r--x11-misc/virtualgl/files/vgl.initd-r230
-rw-r--r--x11-misc/virtualgl/files/vgl.service13
-rw-r--r--x11-misc/virtualgl/metadata.xml24
-rw-r--r--x11-misc/virtualgl/virtualgl-2.3.3.ebuild83
-rw-r--r--x11-misc/virtualgl/virtualgl-2.4.1.ebuild83
8 files changed, 301 insertions, 0 deletions
diff --git a/x11-misc/virtualgl/Manifest b/x11-misc/virtualgl/Manifest
new file mode 100644
index 000000000000..bce7452d197b
--- /dev/null
+++ b/x11-misc/virtualgl/Manifest
@@ -0,0 +1,2 @@
+DIST VirtualGL-2.3.3.tar.gz 2614988 SHA256 857fd5c51c64016a1687cbda62ca5dcdf7073181df86b57be010501b565e5d45 SHA512 7bab5145be338d9bb2f9b4952ee530e84ae195185d55039cf10c89ced049716756f23f4d9c41c82f032c6e6a57bbbaebf023b3e501011bfd5c6aa3d59b22dd8d WHIRLPOOL e903172545c825b8df1dc6678738ac5e7ac2a104ec979668e522f46e2d2f715a3a07cb3cbac57c9e848a6420873f671737b7bed9acf50556a4aea08c4c1355a3
+DIST VirtualGL-2.4.1.tar.gz 1116018 SHA256 2889c6eb35b50340517856f497c07450a9d5ccab46e9b1700a76029a2159cf2e SHA512 b8901eccb29ea21ca1cb0743b6b3a7316ee02422a94be04133daa1c8a24b109e27504a63c901359c7dec22a8af2f0e26d909f9b74c834b97dc19f7491232db0a WHIRLPOOL 2fec19e22eab70cde4a9e4a8a2c9a9628e3e20809e6322b14de53bca50a967f8a142dee147255cb3e9d4d6c802d984b5adbd5293b6bdd205405b92fe18386b95
diff --git a/x11-misc/virtualgl/files/vgl-helper.sh b/x11-misc/virtualgl/files/vgl-helper.sh
new file mode 100644
index 000000000000..805409284862
--- /dev/null
+++ b/x11-misc/virtualgl/files/vgl-helper.sh
@@ -0,0 +1,39 @@
+#!/bin/bash
+
+. /etc/vgl.conf
+
+vgl_start() {
+ truncate --size=0 /var/lib/VirtualGL/vgl_xauth_key
+
+ set_xauth
+ # Check if XAUTHORITY was set successfully, if not wait up to
+ # 60 seconds to allow X start.
+ tries=120
+ while [ ${tries} -gt 0 ]; do
+ tries=$((tries - 1))
+ if [ -z "${XAUTHORITY}" ]; then
+ sleep 0.5
+ set_xauth
+ continue
+ elif [ ! -e "${XAUTHORITY}" ]; then
+ sleep 0.5
+ # fall through, file not existing yet
+ fi
+ break
+ done
+
+ xauth -f /var/lib/VirtualGL/vgl_xauth_key add $DISPLAY . \
+ $(xauth -f $XAUTHORITY list | awk '{print $3;exit}') && \
+ chmod 644 /var/lib/VirtualGL/vgl_xauth_key
+}
+
+vgl_stop() {
+ rm -f /var/lib/VirtualGL/vgl_xauth_key
+}
+
+
+if [ "${1}" = "start" ]; then
+ vgl_start
+elif [ "${1}" = "stop" ]; then
+ vgl_stop
+fi
diff --git a/x11-misc/virtualgl/files/vgl.confd-r1 b/x11-misc/virtualgl/files/vgl.confd-r1
new file mode 100644
index 000000000000..d56414d41110
--- /dev/null
+++ b/x11-misc/virtualgl/files/vgl.confd-r1
@@ -0,0 +1,27 @@
+# /etc/conf.d/vgl
+
+DISPLAY="${DISPLAY:-:0}"
+
+# Make it a function in case we have to repeat it in init script later
+set_xauth() {
+
+# common case (works in almost all tested environments (except of lightdm)):
+XAUTHORITY="$(ps wwax -C X,Xorg -o args= --sort=-stime | grep -m 1 -o '\B[-]auth\s*/var\S*auth\S*' | cut -d ' ' -f 2)"
+
+# kdm and some others:
+# XAUTHORITY="$(find /var/run/xauth/A${DISPLAY}-*|tail -n1)"
+
+# gdm:
+# XAUTHORITY="/var/gdm/${DISPLAY}.Xauth"
+
+# slim:
+# XAUTHORITY="/var/run/slim.auth"
+
+# lightdm:
+# XAUTHORITY="/var/run/lightdm/root/${DISPLAY}"
+
+# lxdm:
+# XAUTHORITY="/var/run/lxdm/lxdm-${DISPLAY}.auth"
+
+}
+set_xauth
diff --git a/x11-misc/virtualgl/files/vgl.initd-r2 b/x11-misc/virtualgl/files/vgl.initd-r2
new file mode 100644
index 000000000000..7d5981f9b8e3
--- /dev/null
+++ b/x11-misc/virtualgl/files/vgl.initd-r2
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: description="*" and other OpenRC 0.9+ candies
+
+depend() {
+ need xdm
+ after sshd
+}
+
+start() {
+ ebegin "Starting VirtualGL"
+ truncate --size=0 /var/lib/VirtualGL/vgl_xauth_key
+
+ # Check if XAUTHORITY was set successfully, if not wait a bit and let X to start
+ [ -z "$XAUTHORITY" ] && sleep 3 && set_xauth
+ [ -e "$XAUTHORITY" ] || sleep 3
+ xauth -f /var/lib/VirtualGL/vgl_xauth_key add $DISPLAY . `xauth -f $XAUTHORITY list | awk '{print $3;exit}'` && \
+ chmod 644 /var/lib/VirtualGL/vgl_xauth_key
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping VirtualGL"
+ [ -f /var/lib/VirtualGL/vgl_xauth_key ] && \
+ rm /var/lib/VirtualGL/vgl_xauth_key
+ eend $?
+}
diff --git a/x11-misc/virtualgl/files/vgl.service b/x11-misc/virtualgl/files/vgl.service
new file mode 100644
index 000000000000..a001e8a1d2f1
--- /dev/null
+++ b/x11-misc/virtualgl/files/vgl.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=VirtualGL service
+After=display-manager.service
+
+[Service]
+RemainAfterExit=yes
+PIDFile=/var/run/named/named.pid
+ExecStart=/usr/libexec/vgl-helper.sh start
+ExecStop=/usr/libexec/vgl-helper.sh stop
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/x11-misc/virtualgl/metadata.xml b/x11-misc/virtualgl/metadata.xml
new file mode 100644
index 000000000000..82630efb1696
--- /dev/null
+++ b/x11-misc/virtualgl/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+ </maintainer>
+ <maintainer>
+ <email>mva@mva.name</email>
+ <name>Vadim A. Misbakh-Soloviov</name>
+ </maintainer>
+ <maintainer>
+ <email>rei4dan@gmail.com</email>
+ <name>My Th</name>
+ </maintainer>
+ <longdescription>
+ An open source package that gives any Unix or Linux remote display software
+ the ability to run OpenGL applications with full 3D hardware acceleration.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">virtualgl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/virtualgl/virtualgl-2.3.3.ebuild b/x11-misc/virtualgl/virtualgl-2.3.3.ebuild
new file mode 100644
index 000000000000..b1780b7c760b
--- /dev/null
+++ b/x11-misc/virtualgl/virtualgl-2.3.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-multilib multilib systemd
+
+DESCRIPTION="Run OpenGL applications remotely with full 3D hardware acceleration"
+HOMEPAGE="http://www.virtualgl.org/"
+
+MY_PN="VirtualGL"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1 wxWinLL-3.1 FLTK"
+KEYWORDS="amd64 x86"
+IUSE="ssl"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl[${MULTILIB_USEDEP}] )
+ media-libs/libjpeg-turbo[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXv[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}]
+ virtual/opengl[${MULTILIB_USEDEP}]
+ amd64? ( abi_x86_32? (
+ >=media-libs/libjpeg-turbo-1.3.0-r3[abi_x86_32]
+ >=x11-libs/libX11-1.6.2[abi_x86_32]
+ >=x11-libs/libXext-1.3.2[abi_x86_32]
+ >=x11-libs/libXv-1.0.10[abi_x86_32]
+ >=virtual/glu-9.0-r1[abi_x86_32]
+ >=virtual/opengl-7.0-r1[abi_x86_32]
+ ) )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Use /var/lib, bug #428122
+ sed -e "s#/etc/opt#/var/lib#g" -i doc/unixconfig.txt doc/index.html doc/advancedopengl.txt \
+ server/vglrun server/vglgenkey server/vglserver_config || die
+
+ default
+}
+
+src_configure() {
+ abi_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use ssl VGL_USESSL)
+ -DVGL_DOCDIR=/usr/share/doc/"${P}"
+ -DTJPEG_INCLUDE_DIR=/usr/include
+ -DVGL_LIBDIR=/usr/$(get_libdir)
+ -DTJPEG_LIBRARY=/usr/$(get_libdir)/libturbojpeg.so
+ -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir)
+ -DVGL_FAKELIBDIR=/usr/fakelib/${ABI}
+ )
+ cmake-utils_src_configure
+ }
+ multilib_parallel_foreach_abi abi_configure
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ # Make config dir
+ dodir /var/lib/VirtualGL
+ fowners root:video /var/lib/VirtualGL
+ fperms 0750 /var/lib/VirtualGL
+ newinitd "${FILESDIR}/vgl.initd-r2" vgl
+ newconfd "${FILESDIR}/vgl.confd-r1" vgl
+
+ exeinto /usr/libexec
+ doexe "${FILESDIR}/vgl-helper.sh"
+ systemd_dounit "${FILESDIR}/vgl.service"
+
+ # Rename glxinfo to vglxinfo to avoid conflict with x11-apps/mesa-progs
+ mv "${D}"/usr/bin/{,v}glxinfo || die
+
+ # Remove license files, bug 536284
+ rm "${D}"/usr/share/doc/${PF}/{LGPL.txt*,LICENSE*} || die
+}
diff --git a/x11-misc/virtualgl/virtualgl-2.4.1.ebuild b/x11-misc/virtualgl/virtualgl-2.4.1.ebuild
new file mode 100644
index 000000000000..e9767e88f1a3
--- /dev/null
+++ b/x11-misc/virtualgl/virtualgl-2.4.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-multilib multilib systemd
+
+DESCRIPTION="Run OpenGL applications remotely with full 3D hardware acceleration"
+HOMEPAGE="http://www.virtualgl.org/"
+
+MY_PN="VirtualGL"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+SRC_URI="mirror://sourceforge/${PN}/files/${PV}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1 wxWinLL-3.1 FLTK"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl[${MULTILIB_USEDEP}] )
+ media-libs/libjpeg-turbo[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXv[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}]
+ virtual/opengl[${MULTILIB_USEDEP}]
+ amd64? ( abi_x86_32? (
+ >=media-libs/libjpeg-turbo-1.3.0-r3[abi_x86_32]
+ >=x11-libs/libX11-1.6.2[abi_x86_32]
+ >=x11-libs/libXext-1.3.2[abi_x86_32]
+ >=x11-libs/libXv-1.0.10[abi_x86_32]
+ >=virtual/glu-9.0-r1[abi_x86_32]
+ >=virtual/opengl-7.0-r1[abi_x86_32]
+ ) )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Use /var/lib, bug #428122
+ sed -e "s#/etc/opt#/var/lib#g" -i doc/unixconfig.txt doc/index.html doc/advancedopengl.txt \
+ server/vglrun.in server/vglgenkey server/vglserver_config || die
+
+ default
+}
+
+src_configure() {
+ abi_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use ssl VGL_USESSL)
+ -DVGL_DOCDIR=/usr/share/doc/"${P}"
+ -DTJPEG_INCLUDE_DIR=/usr/include
+ -DVGL_LIBDIR=/usr/$(get_libdir)
+ -DTJPEG_LIBRARY=/usr/$(get_libdir)/libturbojpeg.so
+ -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir)
+ -DVGL_FAKELIBDIR=/usr/fakelib/${ABI}
+ )
+ cmake-utils_src_configure
+ }
+ multilib_parallel_foreach_abi abi_configure
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ # Make config dir
+ dodir /var/lib/VirtualGL
+ fowners root:video /var/lib/VirtualGL
+ fperms 0750 /var/lib/VirtualGL
+ newinitd "${FILESDIR}/vgl.initd-r2" vgl
+ newconfd "${FILESDIR}/vgl.confd-r1" vgl
+
+ exeinto /usr/libexec
+ doexe "${FILESDIR}/vgl-helper.sh"
+ systemd_dounit "${FILESDIR}/vgl.service"
+
+ # Rename glxinfo to vglxinfo to avoid conflict with x11-apps/mesa-progs
+ mv "${D}"/usr/bin/{,v}glxinfo || die
+
+ # Remove license files, bug 536284
+ rm "${D}"/usr/share/doc/${PF}/{LGPL.txt*,LICENSE*} || die
+}