summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xlockmore/xlockmore-5.45.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xlockmore/xlockmore-5.45.ebuild')
-rw-r--r--x11-misc/xlockmore/xlockmore-5.45.ebuild103
1 files changed, 103 insertions, 0 deletions
diff --git a/x11-misc/xlockmore/xlockmore-5.45.ebuild b/x11-misc/xlockmore/xlockmore-5.45.ebuild
new file mode 100644
index 000000000000..13a8428efc07
--- /dev/null
+++ b/x11-misc/xlockmore/xlockmore-5.45.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic pam
+
+DESCRIPTION="Just another screensaver application for X"
+HOMEPAGE="http://www.tux.org/~bagleyd/xlockmore.html"
+SRC_URI="http://ftp.tux.org/pub/tux/bagleyd/${PN}/${P}/${P}.tar.bz2"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ppc ppc64 sparc x86"
+IUSE="crypt debug gtk imagemagick motif nas opengl pam truetype xinerama xlockrc"
+
+REQUIRED_USE="
+ || ( crypt pam )
+ pam? ( !xlockrc )
+ xlockrc? ( !pam )
+"
+RDEPEND="
+ gtk? ( x11-libs/gtk+:2 )
+ imagemagick? ( media-gfx/imagemagick )
+ motif? ( >=x11-libs/motif-2.3:0 )
+ nas? ( media-libs/nas )
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ truetype? ( >=media-libs/ftgl-2.1.3_rc5 )
+ )
+ pam? ( virtual/pam )
+ truetype? ( media-libs/freetype:2 )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xineramaproto"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-5.31-configure.in.patch \
+ "${FILESDIR}"/${PN}-5.31-ldflags.patch \
+ "${FILESDIR}"/${PN}-5.43-freetype251.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=""
+
+ if use opengl && use truetype; then
+ myconf="${myconf} --with-ftgl"
+ append-flags -DFTGL213
+ else
+ myconf="${myconf} --without-ftgl"
+ fi
+
+ econf \
+ $(use_enable pam) \
+ $(use_enable xlockrc) \
+ $(use_with crypt) \
+ $(use_with debug editres) \
+ $(use_with gtk gtk2) \
+ $(use_with imagemagick magick) \
+ $(use_with motif) \
+ $(use_with nas) \
+ $(use_with opengl mesa) \
+ $(use_with opengl) \
+ $(use_with truetype freetype) \
+ $(use_with truetype ttf) \
+ $(use_with xinerama) \
+ --disable-mb \
+ --enable-appdefaultdir=/usr/share/X11/app-defaults \
+ --enable-syslog \
+ --enable-vtlock \
+ --without-esound \
+ --without-gtk \
+ ${myconf}
+}
+
+src_install() {
+ einstall xapploaddir="${D}/usr/share/X11/app-defaults" \
+ mandir="${D}/usr/share/man/man1" INSTPGMFLAGS=""
+
+ pamd_mimic_system xlock auth
+
+ if use pam; then
+ fperms 755 /usr/bin/xlock
+ else
+ fperms 4755 /usr/bin/xlock
+ fi
+
+ dohtml docs/xlock.html
+ dodoc README docs/{3d.howto,cell_automata,HACKERS.GUIDE,Purify,Revisions,TODO}
+}