summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-04-06 16:23:21 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-13 12:09:53 +0300
commit8af62f38c7986c4f2943e2d97504562a3453244d (patch)
tree29754b66127923b021b1336467c2edc9d8708034 /x11-misc/xrootconsole
parentmedia-libs/libmpris2client: fix RDEPEND, use xdg.eclass (diff)
downloadgentoo-8af62f38c7986c4f2943e2d97504562a3453244d.tar.gz
gentoo-8af62f38c7986c4f2943e2d97504562a3453244d.tar.bz2
gentoo-8af62f38c7986c4f2943e2d97504562a3453244d.zip
x11-misc/xrootconsole: EAPI8 bump, fix LICENSE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/36140 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'x11-misc/xrootconsole')
-rw-r--r--x11-misc/xrootconsole/xrootconsole-0.6-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-misc/xrootconsole/xrootconsole-0.6-r2.ebuild b/x11-misc/xrootconsole/xrootconsole-0.6-r2.ebuild
new file mode 100644
index 000000000000..1ed3bf5912a3
--- /dev/null
+++ b/x11-misc/xrootconsole/xrootconsole-0.6-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility that displays its input in a text box on your root window"
+HOMEPAGE="https://sourceforge.net/projects/xrootconsole/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}.noversion.patch"
+ "${FILESDIR}/${P}.makefile.patch"
+ "${FILESDIR}/${P}.manpage.patch"
+)
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+ emake
+}
+
+src_install() {
+ dodir /usr/bin
+
+ emake \
+ MANDIR="${ED}/usr/share/man/man1" \
+ BINDIR="${ED}/usr/bin/" \
+ install
+
+ einstalldocs
+}