summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-04 14:16:08 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-04 14:16:38 +0200
commit0b6da079deb0925ceb65a68d123c25b4081e3d94 (patch)
tree9846f54a78ce2a609da8360ade703af15a1ad6d8 /x11-misc/xsensors/xsensors-0.80.ebuild
parentmedia-sound/sox: security cleanup (diff)
downloadgentoo-0b6da079deb0925ceb65a68d123c25b4081e3d94.tar.gz
gentoo-0b6da079deb0925ceb65a68d123c25b4081e3d94.tar.bz2
gentoo-0b6da079deb0925ceb65a68d123c25b4081e3d94.zip
x11-misc/xsensors: Version 0.80
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/xsensors/xsensors-0.80.ebuild')
-rw-r--r--x11-misc/xsensors/xsensors-0.80.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/xsensors/xsensors-0.80.ebuild b/x11-misc/xsensors/xsensors-0.80.ebuild
new file mode 100644
index 000000000000..455f446c5635
--- /dev/null
+++ b/x11-misc/xsensors/xsensors-0.80.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A hardware health information viewer, interface to lm-sensors"
+HOMEPAGE="https://github.com/Mystro256/xsensors/"
+SRC_URI="https://github.com/Mystro256/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=sys-apps/lm-sensors-3
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/-DG.*_DISABLE_DEPRECATED/d' \
+ -e 's#-Werror#-Wall#g' \
+ -e 's#==#=#g' \
+ -e 's#pkg-config#${PKG_CONFIG}#g' \
+ src/Makefile.am configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --without-gtk2
+}
+
+src_install() {
+ default
+
+ rm -r "${ED}"/usr/share/appdata || die
+}