summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-03-31 13:35:22 +0200
committerSam James <sam@gentoo.org>2022-04-21 20:54:35 +0100
commit47613a8b7f202daa0c1cfe1cdb12cbb8a7e5bf98 (patch)
treec86511ca41bdd18236cad6988e556bc16feb354a /x11-plugins/gkrellmoon
parentx11-plugins/gkrellm-xkb: update EAPI 6 -> 8 (diff)
downloadgentoo-47613a8b7f202daa0c1cfe1cdb12cbb8a7e5bf98.tar.gz
gentoo-47613a8b7f202daa0c1cfe1cdb12cbb8a7e5bf98.tar.bz2
gentoo-47613a8b7f202daa0c1cfe1cdb12cbb8a7e5bf98.zip
x11-plugins/gkrellmoon: update EAPI 6 -> 8
Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins/gkrellmoon')
-rw-r--r--x11-plugins/gkrellmoon/files/gkrellmoon-0.6-r3-include-stringh.patch14
-rw-r--r--x11-plugins/gkrellmoon/files/gkrellmoon-0.6-r3-pkgconfig.patch12
-rw-r--r--x11-plugins/gkrellmoon/gkrellmoon-0.6-r3.ebuild31
3 files changed, 57 insertions, 0 deletions
diff --git a/x11-plugins/gkrellmoon/files/gkrellmoon-0.6-r3-include-stringh.patch b/x11-plugins/gkrellmoon/files/gkrellmoon-0.6-r3-include-stringh.patch
new file mode 100644
index 000000000000..fc07da13f75b
--- /dev/null
+++ b/x11-plugins/gkrellmoon/files/gkrellmoon-0.6-r3-include-stringh.patch
@@ -0,0 +1,14 @@
+Include string.h
+--- a/CalcEphem.h
++++ b/CalcEphem.h
+@@ -13,6 +13,7 @@
+ #include <glib.h>
+
+ #include <stdio.h>
++#include <string.h>
+ #include <math.h>
+
+ #define DegPerRad 57.29577951308232087680
+--
+2.34.1
+
diff --git a/x11-plugins/gkrellmoon/files/gkrellmoon-0.6-r3-pkgconfig.patch b/x11-plugins/gkrellmoon/files/gkrellmoon-0.6-r3-pkgconfig.patch
new file mode 100644
index 000000000000..80f7fa1a9a3e
--- /dev/null
+++ b/x11-plugins/gkrellmoon/files/gkrellmoon-0.6-r3-pkgconfig.patch
@@ -0,0 +1,12 @@
+Respect user's pkg-config
+--- a/Makefile
++++ b/Makefile
+@@ -1,5 +1,6 @@
+-GTK_INCLUDE = `pkg-config gtk+-2.0 --cflags`
+-GTK_LIB = `pkg-config gtk+-2.0 --libs`
++PKG_CONFIG ?= pkg-config
++GTK_INCLUDE = $(shell ${PKG_CONFIG} gtk+-2.0 --cflags)
++GTK_LIB = $(shel ${PKG_CONFIG} gtk+-2.0 --libs)
+
+ INSTALLDIR = ${DESTDIR}/usr/lib/gkrellm2/plugins
+
diff --git a/x11-plugins/gkrellmoon/gkrellmoon-0.6-r3.ebuild b/x11-plugins/gkrellmoon/gkrellmoon-0.6-r3.ebuild
new file mode 100644
index 000000000000..35005ac0c50a
--- /dev/null
+++ b/x11-plugins/gkrellmoon/gkrellmoon-0.6-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="A GKrellM2 plugin of the famous wmMoonClock dockapp"
+HOMEPAGE="http://gkrellmoon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gkrellmoon/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ media-libs/imlib2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-r3-pkgconfig.patch
+ "${FILESDIR}"/${P}-r3-include-stringh.patch
+)
+
+src_compile() {
+ tc-export PKG_CONFIG
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}