summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-16 03:21:51 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-16 03:25:13 -0400
commit5b7011824d4afdc77c1cd28a2d46445208c77145 (patch)
tree3fddc647b1203617761bcf0be40fc90e595592b5 /x11-terms/kitty
parentnet-im/mattermost-desktop-bin: drop 5.5.1-r1 (diff)
downloadgentoo-5b7011824d4afdc77c1cd28a2d46445208c77145.tar.gz
gentoo-5b7011824d4afdc77c1cd28a2d46445208c77145.tar.bz2
gentoo-5b7011824d4afdc77c1cd28a2d46445208c77145.zip
x11-terms/kitty: backport fix for non-x86/amd64/arm64
Only tested on amd64 by forcing CPPFLAGS=-DKITTY_NO_SIMD which fails like it would on any arches where simde is not used. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty')
-rw-r--r--x11-terms/kitty/files/kitty-0.33.0-no-simd.patch12
-rw-r--r--x11-terms/kitty/kitty-0.33.0.ebuild4
2 files changed, 16 insertions, 0 deletions
diff --git a/x11-terms/kitty/files/kitty-0.33.0-no-simd.patch b/x11-terms/kitty/files/kitty-0.33.0-no-simd.patch
new file mode 100644
index 000000000000..c1366c0ce73c
--- /dev/null
+++ b/x11-terms/kitty/files/kitty-0.33.0-no-simd.patch
@@ -0,0 +1,12 @@
+Backport of fix for -DKITTY_NO_SIMD (aka for non-x86/amd64/arm64)
+https://github.com/kovidgoyal/kitty/issues/7225
+https://github.com/kovidgoyal/kitty/commit/393169f79daf60c038b3e11e657fa5f3ee41c24c
+--- a/kitty/simd-string-impl.h
++++ b/kitty/simd-string-impl.h
+@@ -21,5 +21,5 @@
+ bool FUNC(utf8_decode_to_esc)(UTF8Decoder *d UNUSED, const uint8_t *src UNUSED, size_t src_sz UNUSED) NOSIMD
+ const uint8_t* FUNC(find_either_of_two_bytes)(const uint8_t *haystack UNUSED, const size_t sz UNUSED, const uint8_t a UNUSED, const uint8_t b UNUSED) NOSIMD
+-void FUNC(xor_data64)(const uint8_t key[64], uint8_t* data, const size_t data_sz);
++void FUNC(xor_data64)(const uint8_t key[64] UNUSED, uint8_t* data UNUSED, const size_t data_sz UNUSED) NOSIMD
+ #undef NOSIMD
+ #else
diff --git a/x11-terms/kitty/kitty-0.33.0.ebuild b/x11-terms/kitty/kitty-0.33.0.ebuild
index 19f68cbfc354..0b8a2e645268 100644
--- a/x11-terms/kitty/kitty-0.33.0.ebuild
+++ b/x11-terms/kitty/kitty-0.33.0.ebuild
@@ -84,6 +84,10 @@ BDEPEND="
QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
+PATCHES=(
+ "${FILESDIR}"/${P}-no-simd.patch
+)
+
src_unpack() {
if [[ ${PV} == 9999 ]]; then
git-r3_src_unpack