summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-06 01:41:25 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-06 01:43:59 -0400
commitb7e42b836c0b0034edac9d54273a1035449974d3 (patch)
tree8efad26b67d912b9c3170227c886c6f9ccaa2874 /x11-terms/kitty
parentx11-terms/kitty-shell-integration: add 0.36.2 (diff)
downloadgentoo-b7e42b836c0b0034edac9d54273a1035449974d3.tar.gz
gentoo-b7e42b836c0b0034edac9d54273a1035449974d3.tar.bz2
gentoo-b7e42b836c0b0034edac9d54273a1035449974d3.zip
x11-terms/kitty: add 0.36.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty')
-rw-r--r--x11-terms/kitty/Manifest3
-rw-r--r--x11-terms/kitty/kitty-0.36.2.ebuild187
2 files changed, 190 insertions, 0 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index f38abdf18127..583a333d6c67 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -4,3 +4,6 @@ DIST kitty-0.35.2.tar.xz.sig 566 BLAKE2B 89e636f2fcd8ee12be37e41187d131d2092e667
DIST kitty-0.36.1-vendor.tar.xz 1559304 BLAKE2B 11eee577a24b3fbdf9fa1aa9a9acf5f089804ce4634a69e89194139f70fafd120f9dcd87d17882a2d2695101b3cfdb55371dfafa5e65cafc10690699139d7f53 SHA512 84b42ff0ae6af16f80005df06d79ed237560a1fdbb6c4f8eb7436b988f30eae108b5535b84772605f6f5e7ef8e65b49f48309654cbc0144f7b17ddda6865784c
DIST kitty-0.36.1.tar.xz 8850472 BLAKE2B e03c192d1d523ccc6d20db450fa4f7c4ec741df846152e8363090ed28880aaab40fd5a8c832e5285b6834568730f422353e0bb7e02388e254410ce714f29aa57 SHA512 503ecfc83e367b3f2aacc1bf7849345ef4a50cae69e496325b573660d1fe592cc778d0f9d0d06d5e46210659f4b65b3a7be7dfe1e219565b7371c1848643e111
DIST kitty-0.36.1.tar.xz.sig 566 BLAKE2B 849762f3fe1702ad6104bb94bf04c1d7717796a2761e2a3b1de3d7a8504ed4f86949d18b1c3743e5194e90f373cb0d82d0df3677e33cd4a19a15569147fa74d9 SHA512 259d537b88553bc8ab0761e23c3455e10b7a024e1c71dbeea2f8d0c4514e35f8fe56d298d460d51ab450ee05e731009b06d48c3c996e297f2afd2aa787243cdf
+DIST kitty-0.36.2-vendor.tar.xz 1560776 BLAKE2B 4ddda6bb3a7742d5c0604c40ba4f43be85f86b2b9bd4c390d8b1b64a8df468af606c2697b84b804ddf69ea78179bb4ea542183d4bc3bae7986bb351c83102d0d SHA512 236ce747fafa5e2d291ccee0447b21ed31858548f912b128b5c50fd278a20010eb3b3a5b99706a3f6445e0ece8c8f97e8f2608a7c89e30341c9c847c0d460093
+DIST kitty-0.36.2.tar.xz 8899200 BLAKE2B ab7896c9b5f4a3b428a880663f000618cafff5e1837df693d56b0c7c5364aa7acfb8dd472886935594ecff05be30821c68e2fdc598a530ee36c55031956c2998 SHA512 14efd609f87aa50adc26585e80d3fa80328cbda7b0352eb1689ea585c24cc03fec06424e28d1278b4db6aa8f98ef1faf132ea602637d7781947b72bed53d4784
+DIST kitty-0.36.2.tar.xz.sig 566 BLAKE2B 03d75daa5163ac352210d8cd65b528b0cd558e95403296f8d5850a5721c5e4b1bbe01d3b0cda0f7dfa0b0b371708e6785d5e6cb13242aa07602a871908b77532 SHA512 76f4c117557a483874ecd7fcf169b1e2c7de07e9bd80a8dc3063a5d7620378664186a5deb62f8affb5ffdf8fcafafea54e0963fda1b9b38b8f9487f7837441d7
diff --git a/x11-terms/kitty/kitty-0.36.2.ebuild b/x11-terms/kitty/kitty-0.36.2.ebuild
new file mode 100644
index 000000000000..5b29cd01b6e8
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.36.2.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit edo go-env optfeature multiprocessing
+inherit python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+else
+ inherit verify-sig
+ SRC_URI="
+ https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~ionen/distfiles/${P}-vendor.tar.xz
+ verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )
+ "
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kovidgoyal.gpg
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Fast, feature-rich, GPU-based terminal"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+
+LICENSE="GPL-3 ZLIB"
+LICENSE+=" Apache-2.0 BSD BSD-2 MIT MPL-2.0" # go
+SLOT="0"
+IUSE="+X test wayland"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( X wayland )
+ test? ( X wayland )
+"
+RESTRICT="!test? ( test )"
+
+# dlopen: fontconfig,libglvnd
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/openssl:=
+ dev-libs/xxhash
+ media-fonts/symbols-nerd-font
+ media-libs/fontconfig
+ media-libs/harfbuzz:=[truetype]
+ media-libs/lcms:2
+ media-libs/libglvnd[X?]
+ media-libs/libpng:=
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libxkbcommon[X?]
+ x11-misc/xkeyboard-config
+ ~x11-terms/kitty-shell-integration-${PV}
+ ~x11-terms/kitty-terminfo-${PV}
+ X? (
+ x11-libs/libX11
+ x11-libs/libXcursor
+ )
+ wayland? ( dev-libs/wayland )
+ !sci-mathematics/kissat
+"
+DEPEND="
+ ${RDEPEND}
+ amd64? ( >=dev-libs/simde-0.8.0-r1 )
+ arm64? ( dev-libs/simde )
+ x86? ( dev-libs/simde )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ wayland? ( dev-libs/wayland-protocols )
+"
+# bug #919751 wrt go subslot
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/go-1.23:=
+ sys-libs/ncurses
+ virtual/pkgconfig
+ test? ( $(python_gen_cond_dep 'dev-python/pillow[${PYTHON_USEDEP}]') )
+ wayland? ( dev-util/wayland-scanner )
+"
+[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+
+QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ edo go mod vendor
+ else
+ use verify-sig &&
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # sed unfortunately feels easier on maintenance than patches here
+ local sedargs=(
+ -e "/num_workers =/s/=.*/= $(makeopts_jobs)/"
+ -e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//'
+ -e "s/cflags.append(fortify_source)/pass/" # use toolchain's _f_s
+ -e "s/ld_flags.append('-[sw]')/pass/"
+ )
+
+ # kitty is often popular on wayland-only setups, try to allow this
+ use !X && sedargs+=( -e '/gl_libs =/s/=.*/= []/' ) #857918
+ use !X || use !wayland &&
+ sedargs+=( -e "s/'x11 wayland'/'$(usex X x11 wayland)'/" )
+
+ # skip docs for live version, missing dependencies
+ [[ ${PV} == 9999 ]] && sedargs+=( -e '/exists.*_build/,/docs(ddir)/d' )
+
+ sed -i setup.py "${sedargs[@]}" || die
+
+ local skiptests=(
+ # relies on 'who' command which doesn't detect users with pid-sandbox
+ kitty_tests/utmp.py
+ # may fail/hang depending on environment and shell initialization
+ kitty_tests/{shell_integration,ssh}.py
+ # relies on /proc/self/fd and gets confused when ran from here
+ tools/utils/tpmfile_test.go
+ )
+ use !test || rm "${skiptests[@]}" || die
+}
+
+src_compile() {
+ tc-export CC
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ go-env_set_compile_environment
+ local -x GOFLAGS="-p=$(makeopts_jobs) -v -x -buildvcs=false"
+ use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
+
+ local conf=(
+ --disable-link-time-optimization
+ --ignore-compiler-warnings
+ --libdir-name=$(get_libdir)
+ --shell-integration="enabled no-rc no-sudo"
+ --update-check-interval=0
+ --verbose
+ )
+
+ edo "${EPYTHON}" setup.py linux-package "${conf[@]}"
+ use test && edo "${EPYTHON}" setup.py build-launcher "${conf[@]}"
+
+ rm -r linux-package/share/terminfo || die # provided by kitty-terminfo
+
+ if [[ ${PV} == 9999 ]]; then
+ mkdir -p linux-package/share/doc/${PF} || die
+ else
+ mv linux-package/share/doc/{${PN},${PF}} || die
+ fi
+
+ # generate default config as reference, command taken from docs/conf.rst
+ if ! tc-is-cross-compiler; then
+ linux-package/bin/kitty +runpy \
+ 'from kitty.config import *; print(commented_out_default_config())' \
+ > linux-package/share/doc/${PF}/kitty.conf || die
+ fi
+}
+
+src_test() {
+ KITTY_CONFIG_DIRECTORY=${T} ./test.py || die # shebang is kitty
+}
+
+src_install() {
+ edo mv linux-package "${ED}"/usr
+
+ # kitty currently detects and copies the system's nerd font at build
+ # time, then uses that rather than the system's at runtime
+ dosym -r /usr/share/fonts/symbols-nerd-font/SymbolsNerdFontMono-Regular.ttf \
+ /usr/"$(get_libdir)"/kitty/fonts/SymbolsNerdFontMono-Regular.ttf
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "audio-based terminal bell support" media-libs/libcanberra
+ use X && optfeature "X11 startup notification support" x11-libs/startup-notification
+ optfeature "opening links from the terminal" x11-misc/xdg-utils
+}