summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/icewm/files/icewm-1.3.8-uclibc.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/icewm/files/icewm-1.3.8-uclibc.patch')
-rw-r--r--x11-wm/icewm/files/icewm-1.3.8-uclibc.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/x11-wm/icewm/files/icewm-1.3.8-uclibc.patch b/x11-wm/icewm/files/icewm-1.3.8-uclibc.patch
new file mode 100644
index 000000000000..e790842faed8
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.3.8-uclibc.patch
@@ -0,0 +1,64 @@
+diff -Naur icewm-1.3.7.orig/configure.in icewm-1.3.7/configure.in
+--- icewm-1.3.7.orig/configure.in 2010-10-31 10:09:37.000000000 -0400
++++ icewm-1.3.7/configure.in 2013-10-19 06:20:22.947520430 -0400
+@@ -113,6 +113,7 @@
+ AC_CHECK_HEADERS(libgen.h) dnl -- basename() for FreeBSD
+ AC_CHECK_HEADERS(machine/apmvar.h)
+ AC_CHECK_HEADERS(machine/apm_bios.h)
++AC_CHECK_HEADERS(execinfo.h)
+
+ AC_CHECK_HEADERS(kstat.h,
+ [ CORE_LIBS="${CORE_LIBS} -lkstat"
+diff -Naur icewm-1.3.7.orig/src/acpustatus.cc icewm-1.3.7/src/acpustatus.cc
+--- icewm-1.3.7.orig/src/acpustatus.cc 2010-10-31 10:09:36.000000000 -0400
++++ icewm-1.3.7/src/acpustatus.cc 2013-10-19 06:20:18.355519888 -0400
+@@ -25,17 +25,12 @@
+ #include "sysdep.h"
+ #include "default.h"
+
+-#if defined(linux)
+-//#include <linux/kernel.h>
+-#include <sys/sysinfo.h>
+-#endif
+ #if defined(sun) && defined(SVR4)
+ #include <sys/loadavg.h>
+ #endif
+ #ifdef HAVE_KSTAT_H
+ #include <sys/resource.h>
+ #include <kstat.h>
+-#include <sys/sysinfo.h>
+ #endif
+
+ #ifdef HAVE_SYS_PARAM_H
+@@ -56,6 +51,10 @@
+ #include <dirent.h>
+ #include "intl.h"
+
++#if defined(linux) || defined(HAVE_KSTAT_H)
++#include <sys/sysinfo.h>
++#endif
++
+ #if (defined(linux) || defined(HAVE_KSTAT_H)) || defined(HAVE_SYSCTL_CP_TIME)
+
+ extern ref<YPixmap> taskbackPixmap;
+diff -Naur icewm-1.3.7.orig/src/misc.cc icewm-1.3.7/src/misc.cc
+--- icewm-1.3.7.orig/src/misc.cc 2010-10-31 10:09:36.000000000 -0400
++++ icewm-1.3.7/src/misc.cc 2013-10-19 06:20:22.947520430 -0400
+@@ -15,7 +15,7 @@
+ #include <libgen.h>
+ #endif
+
+-#ifdef linux
++#if defined(linux) && defined(HAVE_EXECINFO_H)
+ #include <execinfo.h>
+ #endif
+
+@@ -503,7 +503,7 @@
+ }
+
+ void show_backtrace() {
+-#ifdef linux
++#if defined(linux) && defined(HAVE_EXECINFO_H)
+ const char head[] = "\nbacktrace:\n";
+ const char tail[] = "end\n";
+ void *array[20];