summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-10-21 12:57:43 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-10-23 21:07:36 +0200
commit7c11175f01e76a1e98b48f9b0efe039e7cb745b4 (patch)
tree19d0a53fe404ec55aabb1c0cb9eb50f4dfbcb244 /x11-wm
parentgnome-base/gnome-panel: add 3.54.0 (diff)
downloadgentoo-7c11175f01e76a1e98b48f9b0efe039e7cb745b4.tar.gz
gentoo-7c11175f01e76a1e98b48f9b0efe039e7cb745b4.tar.bz2
gentoo-7c11175f01e76a1e98b48f9b0efe039e7cb745b4.zip
x11-wm/metacity: add 3.54.0
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/metacity/Manifest1
-rw-r--r--x11-wm/metacity/metacity-3.54.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-wm/metacity/Manifest b/x11-wm/metacity/Manifest
index 4b3d6259ac05..67f7ac73795e 100644
--- a/x11-wm/metacity/Manifest
+++ b/x11-wm/metacity/Manifest
@@ -1 +1,2 @@
DIST metacity-3.52.0.tar.xz 1960156 BLAKE2B e8d078f08c4d3a40a98b5d95aa0286adc4da518ca6a495768d9e31626862b03a3ad5da26928ccc3f337b9811fd5ffa927a37e5f9ab6a7b7c256052842207b5cf SHA512 e49c8a45a26b9b43700e50787fef9e02a6c5abc5d8a809542acaf32f6e15ea756bf8398883e3c69707908e8556ae726d9764fc09f07b0beaa40f79a1490c361e
+DIST metacity-3.54.0.tar.xz 1796756 BLAKE2B d1bb961feaa76486ae866e8e719e3c4443cb7f76f4fbe407ba0821b8db309a7890c6d88a2853a850de2a5df605b6d2a433bad1470677e953afdc9a9e3e62efee SHA512 81029997b9024bb8075dec0e4184a33697ce3c597c3eb686d30536fbe09db619667f3379f995553ff201850910ab7533739c97126e4cbc4f5066a8bb1e2b143f
diff --git a/x11-wm/metacity/metacity-3.54.0.ebuild b/x11-wm/metacity/metacity-3.54.0.ebuild
new file mode 100644
index 000000000000..e28a9046063d
--- /dev/null
+++ b/x11-wm/metacity/metacity-3.54.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2
+
+DESCRIPTION="GNOME Flashback window manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/metacity/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+IUSE="+libcanberra vulkan xinerama"
+
+# TODO: libgtop could be optional, but no knob
+RDEPEND="
+ >=dev-libs/glib-2.67.3:2
+ >=x11-libs/gtk+-3.24.6:3[X]
+ >=x11-libs/pango-1.2.0
+ >=x11-libs/libXcomposite-0.3
+ >=x11-libs/libXres-1.2
+ >=gnome-base/gsettings-desktop-schemas-3.3.0
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXdamage
+ x11-libs/libXpresent
+ libcanberra? ( media-libs/libcanberra[gtk3] )
+ >=x11-libs/startup-notification-0.7
+ x11-libs/libXcursor
+ gnome-base/libgtop:2=
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXrandr
+ x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libSM
+ gnome-extra/zenity
+ vulkan? ( media-libs/vulkan-loader )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ vulkan? ( dev-util/vulkan-headers )
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+" # autoconf-archive for eautoreconf
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable libcanberra canberra) \
+ $(use_enable xinerama) \
+ $(use_enable vulkan)
+}