summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-17 13:17:59 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-17 13:17:59 +0200
commitf5a9436e023b2821bc0058676f5e44de4787d7bb (patch)
tree2796665c28ad79ff0630564354cf045acca644ea /xfce-base/xfconf
parentsys-devel/clang: Stabilize 15.0.7-r3 x86, #908320 (diff)
downloadgentoo-f5a9436e023b2821bc0058676f5e44de4787d7bb.tar.gz
gentoo-f5a9436e023b2821bc0058676f5e44de4787d7bb.tar.bz2
gentoo-f5a9436e023b2821bc0058676f5e44de4787d7bb.zip
xfce-base/xfconf: Bump to 4.18.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/xfconf')
-rw-r--r--xfce-base/xfconf/Manifest1
-rw-r--r--xfce-base/xfconf/xfconf-4.18.2.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/xfce-base/xfconf/Manifest b/xfce-base/xfconf/Manifest
index 7c02f5a93692..f7e576ecff42 100644
--- a/xfce-base/xfconf/Manifest
+++ b/xfce-base/xfconf/Manifest
@@ -1,2 +1,3 @@
DIST xfconf-4.18.1.tar.bz2 629881 BLAKE2B 1344637b8f29f03e546d432f7703cba3add24d13e9615e3a69adab7050fbae7e0db44aec41dc322e3ee1e7aa744de3d9a41d80bf3d0a0ce9fbd91407d6db31d0 SHA512 cb4cc29497865755df4c9b8db7cbb84f9f2b5ce5eb7216bd5a3e7202424c565a36f4e4592c5ee0035a01fe4df043a87de43a536b0e63e1e200a077631e1c807a
+DIST xfconf-4.18.2.tar.bz2 632500 BLAKE2B b0e28985c1b9cd3c29b534ca620ede881639998ac48f20a5f58bc19cc5f5405baddfd1b24f425a5159770a6034121c2b7a80111fb57df0de6667a804d8aca14d SHA512 d24157e966d3e83edf21ebf6b0745fa4a8518410bc430e94b1f5ec98eb5a1d038056e014fd87813e524c17ce23faf47d6d1a76752e9ee9ec766e1e94517003ca
DIST xfconf-4.19.0.tar.bz2 755578 BLAKE2B 6442da9393c590a0d17e33081f161b115877fef02da9754d2d10baf377473a82a08ef01b007cbabc04637ff3441a1362ca9d3cf922d55a4ac6962389cc9befa9 SHA512 7acf5257996d8d36c50e373f25f6b0aa6ecfe4cecf4df6e18b221f7185f20bdb74a5571d21166ef2e7611c7e089242b0bc09c99a0d3735dc319736a230e7b2e6
diff --git a/xfce-base/xfconf/xfconf-4.18.2.ebuild b/xfce-base/xfconf/xfconf-4.18.2.ebuild
new file mode 100644
index 000000000000..315b4fc9fb79
--- /dev/null
+++ b/xfce-base/xfconf/xfconf-4.18.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 vala
+
+DESCRIPTION="A configuration management system for Xfce"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfconf/start
+ https://gitlab.xfce.org/xfce/xfconf/
+"
+
+LICENSE="GPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ sys-apps/dbus
+ >=xfce-base/libxfce4util-4.17.3:=
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ $(use_enable debug checks)
+ --with-bash-completion-dir="$(get_bashcompdir)"
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ local service_dir=${HOME}/.local/share/dbus-1/services
+ mkdir -p "${service_dir}" || die
+ cat > "${service_dir}/org.xfce.Xfconf.service" <<-EOF || die
+ [D-BUS Service]
+ Name=org.xfce.Xfconf
+ Exec=${S}/xfconfd/xfconfd
+ EOF
+
+ (
+ # start isolated dbus session bus
+ dbus_data=$(dbus-launch --sh-syntax) || exit
+ eval "${dbus_data}"
+
+ # -j>1 often hangs
+ # https://gitlab.xfce.org/xfce/xfconf/-/issues/13
+ nonfatal emake -j1 check
+ ret=${?}
+
+ kill "${DBUS_SESSION_BUS_PID}"
+ exit "${ret}"
+ ) || die
+}
+
+src_install() {
+ default
+ find "${D}" -type f -name '*.la' -delete || die
+}