summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.320.0.ebuild37
-rw-r--r--dev-perl/DateTime-Format-Flexible/Manifest1
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.320.0.ebuild b/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.320.0.ebuild
new file mode 100644
index 000000000000..7b41977acc32
--- /dev/null
+++ b/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.320.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=THINC
+DIST_VERSION=0.32
+DIST_EXAMPLES=( "example/*" )
+inherit perl-module
+
+DESCRIPTION="Flexibly parse strings and turn them into DateTime objects"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/DateTime
+ >=dev-perl/DateTime-Format-Builder-0.740.0
+ dev-perl/DateTime-TimeZone
+ dev-perl/List-MoreUtils
+ dev-perl/Module-Pluggable
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-MockTime
+ dev-perl/Test-NoWarnings
+ >=virtual/perl-Test-Simple-0.440.0
+ )
+"
+PERL_RM_FILES=(
+ t/002_pod.t
+ t/003_podcoverage.t
+)
diff --git a/dev-perl/DateTime-Format-Flexible/Manifest b/dev-perl/DateTime-Format-Flexible/Manifest
index 3169e0c3c5b5..b61519defcb7 100644
--- a/dev-perl/DateTime-Format-Flexible/Manifest
+++ b/dev-perl/DateTime-Format-Flexible/Manifest
@@ -1 +1,2 @@
DIST DateTime-Format-Flexible-0.28.tar.gz 73722 BLAKE2B 38e23f7795ca66154e303eb7260568a27b08af937ffeef2aa61b03a81ad91d55e6a46e08105d564034a8cf02fc00ec87c26ce6510aed76e08ce73d3ec8c16abb SHA512 e74de1cf104a37cf832d5976fd450476a42b945a8fd03ab1ddea504e4041009534cef9e72a75a120ab3ed9a1af63fb05bd5876632b594db9e7f21f419678d2d8
+DIST DateTime-Format-Flexible-0.32.tar.gz 76438 BLAKE2B b7a0f5abdba67e70979c510f13849697a9107eb275d5702ce6eafaa5abed140ee4072778642157f827823badd0f425e861927d5956a4818f6d0ce31c821c28fc SHA512 90e0e83cecff5daab132860c2da2d77c92c0791fe8d0d6aa9275c1e0d603b644a8531848d8fb4bad8e1800c02a4e571ceda1a4bf4b8ee9bd7ac0215898db2882