summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/ghc/ghc-7.10.3.ebuild4
-rw-r--r--dev-lang/ghc/ghc-7.8.4.ebuild2
-rw-r--r--dev-lang/ghc/ghc-8.0.2.ebuild2
-rw-r--r--dev-lang/ghc/ghc-8.10.1.ebuild2
-rw-r--r--dev-lang/ghc/ghc-8.2.1.ebuild4
-rw-r--r--dev-lang/ghc/ghc-8.2.2.ebuild4
-rw-r--r--dev-lang/ghc/ghc-8.4.1.ebuild4
-rw-r--r--dev-lang/ghc/ghc-8.4.2.ebuild4
-rw-r--r--dev-lang/ghc/ghc-8.4.3.ebuild4
-rw-r--r--dev-lang/ghc/ghc-8.6.4.ebuild4
-rw-r--r--dev-lang/ghc/ghc-8.6.5.ebuild2
-rw-r--r--dev-lang/ghc/ghc-8.8.1.ebuild2
-rw-r--r--dev-lang/ghc/ghc-8.8.2.ebuild2
13 files changed, 20 insertions, 20 deletions
diff --git a/dev-lang/ghc/ghc-7.10.3.ebuild b/dev-lang/ghc/ghc-7.10.3.ebuild
index 54f5392481ac..88f76929978c 100644
--- a/dev-lang/ghc/ghc-7.10.3.ebuild
+++ b/dev-lang/ghc/ghc-7.10.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -81,7 +81,7 @@ RDEPEND="
>=dev-lang/perl-5.6.1
>=dev-libs/gmp-5:=
sys-libs/ncurses:0=[unicode]
- !ghcmakebinary? ( virtual/libffi:= )
+ !ghcmakebinary? ( dev-libs/libffi:= )
"
# This set of dependencies is needed to run
diff --git a/dev-lang/ghc/ghc-7.8.4.ebuild b/dev-lang/ghc/ghc-7.8.4.ebuild
index b8865b2c70ef..f15723770fd1 100644
--- a/dev-lang/ghc/ghc-7.8.4.ebuild
+++ b/dev-lang/ghc/ghc-7.8.4.ebuild
@@ -74,7 +74,7 @@ RDEPEND="
>=dev-lang/perl-5.6.1
>=dev-libs/gmp-5:=
sys-libs/ncurses:0=[unicode]
- !ghcmakebinary? ( virtual/libffi:= )
+ !ghcmakebinary? ( dev-libs/libffi:= )
"
PREBUILT_BINARY_DEPENDS="
diff --git a/dev-lang/ghc/ghc-8.0.2.ebuild b/dev-lang/ghc/ghc-8.0.2.ebuild
index f9488abb75ce..4c292fda10a5 100644
--- a/dev-lang/ghc/ghc-8.0.2.ebuild
+++ b/dev-lang/ghc/ghc-8.0.2.ebuild
@@ -79,7 +79,7 @@ RDEPEND="
>=dev-lang/perl-5.6.1
dev-libs/gmp:0=
sys-libs/ncurses:0=[unicode]
- !ghcmakebinary? ( virtual/libffi:= )
+ !ghcmakebinary? ( dev-libs/libffi:= )
"
# This set of dependencies is needed to run
diff --git a/dev-lang/ghc/ghc-8.10.1.ebuild b/dev-lang/ghc/ghc-8.10.1.ebuild
index c1bb998ba2c9..574e2aaec41b 100644
--- a/dev-lang/ghc/ghc-8.10.1.ebuild
+++ b/dev-lang/ghc/ghc-8.10.1.ebuild
@@ -85,7 +85,7 @@ RDEPEND="
dev-libs/gmp:0=
sys-libs/ncurses:0=[unicode]
elfutils? ( dev-libs/elfutils )
- !ghcmakebinary? ( virtual/libffi:= )
+ !ghcmakebinary? ( dev-libs/libffi:= )
numa? ( sys-process/numactl )
"
diff --git a/dev-lang/ghc/ghc-8.2.1.ebuild b/dev-lang/ghc/ghc-8.2.1.ebuild
index 266b59e2bfe8..c701609e940a 100644
--- a/dev-lang/ghc/ghc-8.2.1.ebuild
+++ b/dev-lang/ghc/ghc-8.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -75,7 +75,7 @@ RDEPEND="
>=dev-lang/perl-5.6.1
dev-libs/gmp:0=
sys-libs/ncurses:0=[unicode]
- !ghcmakebinary? ( virtual/libffi:= )
+ !ghcmakebinary? ( dev-libs/libffi:= )
"
# This set of dependencies is needed to run
diff --git a/dev-lang/ghc/ghc-8.2.2.ebuild b/dev-lang/ghc/ghc-8.2.2.ebuild
index 6db8290ea34b..7304fe4bcc2e 100644
--- a/dev-lang/ghc/ghc-8.2.2.ebuild
+++ b/dev-lang/ghc/ghc-8.2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -75,7 +75,7 @@ RDEPEND="
>=dev-lang/perl-5.6.1
dev-libs/gmp:0=
sys-libs/ncurses:0=[unicode]
- !ghcmakebinary? ( virtual/libffi:= )
+ !ghcmakebinary? ( dev-libs/libffi:= )
"
# This set of dependencies is needed to run
diff --git a/dev-lang/ghc/ghc-8.4.1.ebuild b/dev-lang/ghc/ghc-8.4.1.ebuild
index 2fb1025b91f4..bb77c83651a1 100644
--- a/dev-lang/ghc/ghc-8.4.1.ebuild
+++ b/dev-lang/ghc/ghc-8.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -75,7 +75,7 @@ RDEPEND="
>=dev-lang/perl-5.6.1
dev-libs/gmp:0=
sys-libs/ncurses:0=[unicode]
- !ghcmakebinary? ( virtual/libffi:= )
+ !ghcmakebinary? ( dev-libs/libffi:= )
"
# This set of dependencies is needed to run
diff --git a/dev-lang/ghc/ghc-8.4.2.ebuild b/dev-lang/ghc/ghc-8.4.2.ebuild
index 529e6682ff97..1560843584db 100644
--- a/dev-lang/ghc/ghc-8.4.2.ebuild
+++ b/dev-lang/ghc/ghc-8.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -75,7 +75,7 @@ RDEPEND="
>=dev-lang/perl-5.6.1
dev-libs/gmp:0=
sys-libs/ncurses:0=[unicode]
- !ghcmakebinary? ( virtual/libffi:= )
+ !ghcmakebinary? ( dev-libs/libffi:= )
"
# This set of dependencies is needed to run
diff --git a/dev-lang/ghc/ghc-8.4.3.ebuild b/dev-lang/ghc/ghc-8.4.3.ebuild
index 238882613374..8d8af4264738 100644
--- a/dev-lang/ghc/ghc-8.4.3.ebuild
+++ b/dev-lang/ghc/ghc-8.4.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -75,7 +75,7 @@ RDEPEND="
>=dev-lang/perl-5.6.1
dev-libs/gmp:0=
sys-libs/ncurses:0=[unicode]
- !ghcmakebinary? ( virtual/libffi:= )
+ !ghcmakebinary? ( dev-libs/libffi:= )
"
# This set of dependencies is needed to run
diff --git a/dev-lang/ghc/ghc-8.6.4.ebuild b/dev-lang/ghc/ghc-8.6.4.ebuild
index 9400b701afb3..2d192b4e58e0 100644
--- a/dev-lang/ghc/ghc-8.6.4.ebuild
+++ b/dev-lang/ghc/ghc-8.6.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -81,7 +81,7 @@ RDEPEND="
>=dev-lang/perl-5.6.1
dev-libs/gmp:0=
sys-libs/ncurses:0=[unicode]
- !ghcmakebinary? ( virtual/libffi:= )
+ !ghcmakebinary? ( dev-libs/libffi:= )
"
# This set of dependencies is needed to run
diff --git a/dev-lang/ghc/ghc-8.6.5.ebuild b/dev-lang/ghc/ghc-8.6.5.ebuild
index 2e4e523c095c..e95768813eac 100644
--- a/dev-lang/ghc/ghc-8.6.5.ebuild
+++ b/dev-lang/ghc/ghc-8.6.5.ebuild
@@ -85,7 +85,7 @@ RDEPEND="
dev-libs/gmp:0=
sys-libs/ncurses:0=[unicode]
elfutils? ( dev-libs/elfutils )
- !ghcmakebinary? ( virtual/libffi:= )
+ !ghcmakebinary? ( dev-libs/libffi:= )
numa? ( sys-process/numactl )
"
diff --git a/dev-lang/ghc/ghc-8.8.1.ebuild b/dev-lang/ghc/ghc-8.8.1.ebuild
index 7b8c9321190f..8d13a22eea76 100644
--- a/dev-lang/ghc/ghc-8.8.1.ebuild
+++ b/dev-lang/ghc/ghc-8.8.1.ebuild
@@ -84,7 +84,7 @@ RDEPEND="
dev-libs/gmp:0=
sys-libs/ncurses:0=[unicode]
elfutils? ( dev-libs/elfutils )
- !ghcmakebinary? ( virtual/libffi:= )
+ !ghcmakebinary? ( dev-libs/libffi:= )
numa? ( sys-process/numactl )
"
diff --git a/dev-lang/ghc/ghc-8.8.2.ebuild b/dev-lang/ghc/ghc-8.8.2.ebuild
index 0726cf1c9bc7..4d206d287dd2 100644
--- a/dev-lang/ghc/ghc-8.8.2.ebuild
+++ b/dev-lang/ghc/ghc-8.8.2.ebuild
@@ -84,7 +84,7 @@ RDEPEND="
dev-libs/gmp:0=
sys-libs/ncurses:0=[unicode]
elfutils? ( dev-libs/elfutils )
- !ghcmakebinary? ( virtual/libffi:= )
+ !ghcmakebinary? ( dev-libs/libffi:= )
numa? ( sys-process/numactl )
"