summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/rdoc/Manifest2
-rw-r--r--dev-ruby/rdoc/rdoc-6.2.0.ebuild94
-rw-r--r--dev-ruby/rdoc/rdoc-6.3.0.ebuild94
3 files changed, 0 insertions, 190 deletions
diff --git a/dev-ruby/rdoc/Manifest b/dev-ruby/rdoc/Manifest
index fb224ee6f5f7..1c63e605625f 100644
--- a/dev-ruby/rdoc/Manifest
+++ b/dev-ruby/rdoc/Manifest
@@ -1,4 +1,2 @@
DIST rdoc-6.1.2.tar.gz 667607 BLAKE2B 4857bcf5f72d93fe4e9ea89acfda9ae82afd61a7ff501d2eea529330d2b8a63d7cc775490648fcff5000ee60417123244518f56a31593af8efccae8f925b21d9 SHA512 a54e36adf9f98117f0b5ae4490a0ab1ce12d9b1de5b7c61ffa326b36ef13885bb8f18147f3548f95a285b15470faba14965bc87088fa3ce584928d8ee396689f
-DIST rdoc-6.2.0.tar.gz 668152 BLAKE2B 9c92b27c427d6229778aba54ce7f12fe883fd3e40151f518f3d023d4f6dd10d4f1f6d05c8d6bcdce80d1ac81ab25cd99ccbe9479a4fcd950b895e14d4fdc4b83 SHA512 15352889833436c0a243e4f79c4ae8113fa3b8c222950baf1fcd272773a7a17198c2cd91a50c92e225c282a37ec743a38d8e9ca4dffe0b66c39d56412fe56ca2
-DIST rdoc-6.3.0.tar.gz 670538 BLAKE2B a7eda5d588c0089e36ee4197940e762e378de24b45435f8d9fa9ef9292b5d2f50d7b48ed40764794c4a20e8b159ab6f2e0d86a9289c0706744eeec7a016e05e6 SHA512 7e5da42905416d12acf6528b5725ea9fccb7b50bb1ed95c03975d16cc2ad22c58f48c3f14b4f118deb978649cec184b98ccef915a5cb4b0321e0114438f75745
DIST rdoc-6.3.2.tar.gz 675963 BLAKE2B 1ac931ddf0af700f2460e415a6e8c505c9a3c0f2d65b5c25928285144181d925747dad0224f014abdc1680df9130df74ba82750a2cb1d02b042c0bcd63d22e6a SHA512 1bd8eaa6c1e5cc40492b1d6e461d831cfc05bf368c982f3266b63ea4984c10de40523f9e2106b1beebd96933a2006cb81c3daa26ee0196d99d1ed6da5b72a78f
diff --git a/dev-ruby/rdoc/rdoc-6.2.0.ebuild b/dev-ruby/rdoc/rdoc-6.2.0.ebuild
deleted file mode 100644
index ac40c6318c03..000000000000
--- a/dev-ruby/rdoc/rdoc-6.2.0.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc RI.rdoc TODO.rdoc"
-
-RUBY_FAKEGEM_BINWRAP=""
-RUBY_FAKEGEM_BINDIR="exe"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="An extended version of the RDoc library from Ruby 1.8"
-HOMEPAGE="https://github.com/ruby/rdoc/"
-SRC_URI="https://github.com/ruby/rdoc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Ruby MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE="doc"
-
-RDEPEND+=">=app-eselect/eselect-ruby-20181225"
-
-ruby_add_bdepend "
- >=dev-ruby/kpeg-1.1.0-r1
- >dev-ruby/racc-1.4.10
- dev-ruby/rake
- test? (
- dev-ruby/bundler
- >=dev-ruby/minitest-5.8:5
- )"
-
-all_ruby_prepare() {
- # Other packages also have use for a nonexistent directory, bug 321059
- sed -i -e 's#/nonexistent#/nonexistent_rdoc_tests#g' test/rdoc/test_rdoc*.rb || die
-
- # Avoid unneeded dependency on bundler, bug 603696
- sed -i -e '/bundler/ s:^:#:' \
- -e 's/Bundler::GemHelper.gemspec.full_name/"rdoc"/' \
- -e '/rubocop\/rake/ s:^:#:' \
- -e '/RuboCop/,/end/ s:^:#:' Rakefile || die
-
- # Remove test that is depending on the locale, which we can't garantuee.
- sed -i -e '/def test_encode_with/,/^ end/ s:^:#:' test/rdoc/test_rdoc_options.rb || die
-
- # Remove test depending on FEATURES=userpriv, bug 361959
- sed -i -e '/def test_check_files/,/^ end/ s:^:#:' test/rdoc/test_rdoc_options.rb || die
-
- # Remove tests for code that is not included and not listed in Manifest.txt
- rm -f test/test_rdoc_i18n_{locale,text}.rb \
- test/rdoc/test_rdoc_generator_pot* || die
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc ; then
- ruby -Ilib -S exe/rdoc || die
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} -S rake generate || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for bin in rdoc ri; do
- ruby_fakegem_binwrapper $bin /usr/bin/$bin-2
-
- for version in $(ruby_get_use_implementations); do
- version=`echo ${version} | cut -c 5-`
- if use ruby_targets_ruby${version}; then
- ruby_fakegem_binwrapper $bin /usr/bin/${bin}${version}
- sed -i -e "1s/env ruby/ruby${version}/" \
- "${ED}/usr/bin/${bin}${version}" || die
- fi
- done
- done
-}
-
-pkg_postinst() {
- if [[ ! -n $(readlink "${ROOT}"/usr/bin/rdoc) ]] ; then
- eselect ruby set $(eselect --brief --colour=no ruby show | head -n1)
- fi
-}
diff --git a/dev-ruby/rdoc/rdoc-6.3.0.ebuild b/dev-ruby/rdoc/rdoc-6.3.0.ebuild
deleted file mode 100644
index f0b0e0194173..000000000000
--- a/dev-ruby/rdoc/rdoc-6.3.0.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_RECIPE_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc RI.rdoc TODO.rdoc"
-
-RUBY_FAKEGEM_BINWRAP=""
-RUBY_FAKEGEM_BINDIR="exe"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="An extended version of the RDoc library from Ruby 1.8"
-HOMEPAGE="https://github.com/ruby/rdoc/"
-SRC_URI="https://github.com/ruby/rdoc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Ruby MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE="doc"
-
-RDEPEND+=">=app-eselect/eselect-ruby-20181225"
-
-ruby_add_bdepend "
- >=dev-ruby/kpeg-1.1.0-r1
- >dev-ruby/racc-1.4.10
- dev-ruby/rake
- test? (
- dev-ruby/bundler
- >=dev-ruby/minitest-5.8:5
- )"
-
-all_ruby_prepare() {
- # Other packages also have use for a nonexistent directory, bug 321059
- sed -i -e 's#/nonexistent#/nonexistent_rdoc_tests#g' test/rdoc/test_rdoc*.rb || die
-
- # Avoid unneeded dependency on bundler, bug 603696
- sed -i -e '/bundler/ s:^:#:' \
- -e 's/Bundler::GemHelper.gemspec.full_name/"rdoc"/' \
- -e '/rubocop\/rake/ s:^:#:' \
- -e '/RuboCop/,/end/ s:^:#:' Rakefile || die
-
- # Remove test that is depending on the locale, which we can't garantuee.
- sed -i -e '/def test_encode_with/,/^ end/ s:^:#:' test/rdoc/test_rdoc_options.rb || die
-
- # Remove test depending on FEATURES=userpriv, bug 361959
- sed -i -e '/def test_check_files/,/^ end/ s:^:#:' test/rdoc/test_rdoc_options.rb || die
-
- # Remove tests for code that is not included and not listed in Manifest.txt
- rm -f test/test_rdoc_i18n_{locale,text}.rb \
- test/rdoc/test_rdoc_generator_pot* || die
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc ; then
- ruby -Ilib -S exe/rdoc || die
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} -S rake generate || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for bin in rdoc ri; do
- ruby_fakegem_binwrapper $bin /usr/bin/$bin-2
-
- for version in $(ruby_get_use_implementations); do
- version=`echo ${version} | cut -c 5-`
- if use ruby_targets_ruby${version}; then
- ruby_fakegem_binwrapper $bin /usr/bin/${bin}${version}
- sed -i -e "1s/env ruby/ruby${version}/" \
- "${ED}/usr/bin/${bin}${version}" || die
- fi
- done
- done
-}
-
-pkg_postinst() {
- if [[ ! -n $(readlink "${ROOT}"/usr/bin/rdoc) ]] ; then
- eselect ruby set $(eselect --brief --colour=no ruby show | head -n1)
- fi
-}