summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/h2/h2-4.1.0-r1.ebuild18
1 files changed, 2 insertions, 16 deletions
diff --git a/dev-python/h2/h2-4.1.0-r1.ebuild b/dev-python/h2/h2-4.1.0-r1.ebuild
index 7dee9b75abc0..48df5ef3a0e6 100644
--- a/dev-python/h2/h2-4.1.0-r1.ebuild
+++ b/dev-python/h2/h2-4.1.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1
@@ -37,17 +37,3 @@ PATCHES=(
)
distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
- if [[ ${EPYTHON} == python3.11 ]]; then
- EPYTEST_DESELECT+=(
- test/test_events.py::TestEventReprs::test_remotesettingschanged_repr
- test/test_events.py::TestEventReprs::test_streamreset_repr
- test/test_events.py::TestEventReprs::test_settingsacknowledged_repr
- test/test_events.py::TestEventReprs::test_connectionterminated_repr
- )
- fi
-
- epytest
-}