summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libreport/Manifest1
-rw-r--r--dev-libs/libreport/libreport-2.15.2.ebuild100
2 files changed, 0 insertions, 101 deletions
diff --git a/dev-libs/libreport/Manifest b/dev-libs/libreport/Manifest
index 80eb3f59d09c..79692f1cdbb7 100644
--- a/dev-libs/libreport/Manifest
+++ b/dev-libs/libreport/Manifest
@@ -1,3 +1,2 @@
-DIST libreport-2.15.2.tar.gz 1859867 BLAKE2B f890e3cb8b2a23647e4c3fb0caaf984b1b21fd32e066d04f835f8a475e317cbc75287375e0a10a01b91670d04bba1f15b1180065f7029b8d7d1c0a2fb890914b SHA512 c98003325fa70d674177c9f602a7f121815a9675701ee780ad8908ed69862f2c69be65c7483fd3f017ba299dda51ba304f0908c771c9d97cb5bba057e3a9c5dc
DIST libreport-2.16.0.tar.gz 1901880 BLAKE2B 520ad157de02dbe5fd15b2ffcfc9b0a09587c3696b41a202f0a78b53a2d366a2991906437aa38d7c84407dcd4a788d358b9e320f70c30e602f1b903433288717 SHA512 cbb456bb63b92a255fecb87191160c2e515b4434cbaaa9404fb69f4f78421fe98c4057969f4b6b99e1b52e815d83c483bdbbe606a4bd2e34cf5268769e7bd40f
DIST libreport-2.17.1.tar.gz 1904056 BLAKE2B 3bb4bade768e585af620cdf9f0f353528f24145a157a295fed449b6064ab846757946d38db5fd607e82b784156637f02e7eb66e01ac70c170b2006f4edd950f5 SHA512 35c5031e0a361040153ea45a249613b9f2d2bb38191c6375b197cb797be153f1a4b46480dbfa5fcdd9c5c00b075f84997f6da70c3b59b8b8251fd29a7180bd9b
diff --git a/dev-libs/libreport/libreport-2.15.2.ebuild b/dev-libs/libreport/libreport-2.15.2.ebuild
deleted file mode 100644
index debf3b612b4a..000000000000
--- a/dev-libs/libreport/libreport-2.15.2.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit autotools python-r1
-
-DESCRIPTION="Generic library for reporting software bugs"
-HOMEPAGE="https://github.com/abrt/libreport"
-SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0/2"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="gtk +python"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- app-admin/augeas
- app-arch/libarchive:0=
- >=dev-libs/glib-2.43.4:2
- dev-libs/satyr:0=
- dev-libs/json-c:=
- dev-libs/libxml2:2
- dev-libs/nettle:=
- dev-libs/newt:=
- dev-libs/xmlrpc-c:=
- net-libs/libproxy:=
- net-misc/curl:=[ssl]
- sys-apps/dbus
- sys-apps/systemd
- gtk? ( >=x11-libs/gtk+-3.3.12:3 )
- python? ( ${PYTHON_DEPS} )
- x11-misc/xdg-utils
-"
-RDEPEND="${DEPEND}
- acct-user/abrt
- acct-group/abrt
-"
-BDEPEND="
- app-text/asciidoc
- app-text/xmlto
- >=dev-util/intltool-0.3.50
- >=sys-devel/gettext-0.17
- virtual/pkgconfig
-"
-
-# Tests require python-meh, which is highly redhat-specific.
-RESTRICT="test"
-
-src_prepare() {
- default
- ./gen-version || die # Needed to be run before autoreconf
- eautoreconf
- use python && python_copy_sources
-}
-
-src_configure() {
- use python && python_setup
-
- local myargs=(
- --localstatedir="${EPREFIX}/var"
- --without-bugzilla
- $(use_with gtk)
- $(use_with python python3)
- )
- if use python; then
- python_foreach_impl run_in_build_dir econf "${myargs[@]}"
- else
- econf "${myargs[@]}"
- fi
-}
-
-src_compile() {
- if use python; then
- python_foreach_impl run_in_build_dir default
- else
- default
- fi
-}
-
-src_install() {
- if use python; then
- python_install() {
- default
- python_optimize
- }
- python_foreach_impl run_in_build_dir python_install
- else
- default
- fi
-
- # Need to set correct ownership for use by app-admin/abrt
- diropts -o abrt -g abrt
- keepdir /var/spool/abrt
-
- find "${D}" -name '*.la' -exec rm -f {} + || die
-}