summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/folly/folly-2024.11.04.00-r2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-cpp/folly/folly-2024.11.04.00-r2.ebuild b/dev-cpp/folly/folly-2024.11.04.00-r2.ebuild
index 44a95b28d09a..d861968c9242 100644
--- a/dev-cpp/folly/folly-2024.11.04.00-r2.ebuild
+++ b/dev-cpp/folly/folly-2024.11.04.00-r2.ebuild
@@ -13,7 +13,7 @@ EAPI=8
# dev-cpp/wangle
# dev-util/watchman
-inherit flag-o-matic cmake
+inherit flag-o-matic cmake toolchain-funcs
DESCRIPTION="An open-source C++ library developed and used at Facebook"
HOMEPAGE="https://github.com/facebook/folly"
@@ -101,5 +101,13 @@ src_test() {
)
fi
+ if [[ $(tc-get-cxx-stdlib) == libc++ ]]; then
+ CMAKE_SKIP_TESTS+=(
+ # Aborts with libc++.
+ # https://github.com/facebook/folly/issues/2345
+ buffered_atomic_test.BufferedAtomic.singleThreadUnguardedAccess
+ )
+ fi
+
cmake_src_test
}