summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/spacemacs-theme/spacemacs-theme-0.3_p20241101.ebuild')
-rw-r--r--app-emacs/spacemacs-theme/spacemacs-theme-0.3_p20241101.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/spacemacs-theme/spacemacs-theme-0.3_p20241101.ebuild b/app-emacs/spacemacs-theme/spacemacs-theme-0.3_p20241101.ebuild
new file mode 100644
index 000000000000..081ca69c6f7a
--- /dev/null
+++ b/app-emacs/spacemacs-theme/spacemacs-theme-0.3_p20241101.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs color theme that started as a theme for Spacemacs"
+HOMEPAGE="https://github.com/nashamri/spacemacs-theme/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/nashamri/${PN}.git"
+else
+ [[ "${PV}" == *p20241101 ]] && COMMIT="6c74684c4d55713c8359bedf1936e429918a8c33"
+
+ SRC_URI="https://github.com/nashamri/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+ELISP_REMOVE="
+ spacemacs-theme-pkg.el
+"
+
+SITEFILE="50${PN}-gentoo.el"