summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/mina-core/mina-core-1.1.7-r1.ebuild')
-rw-r--r--dev-java/mina-core/mina-core-1.1.7-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/mina-core/mina-core-1.1.7-r1.ebuild b/dev-java/mina-core/mina-core-1.1.7-r1.ebuild
new file mode 100644
index 000000000000..0ebfcd87db58
--- /dev/null
+++ b/dev-java/mina-core/mina-core-1.1.7-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Apache MINA Project"
+HOMEPAGE="http://mina.apache.org/"
+SRC_URI="mirror://gentoo/${P}-sources.jar -> ${P}.jar"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+CDEPEND="dev-java/slf4j-api:0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+S="${WORKDIR}"
+
+JAVA_GENTOO_CLASSPATH="slf4j-api"