summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/spidermonkey/spidermonkey-128.3.0-r1.ebuild')
-rw-r--r--dev-lang/spidermonkey/spidermonkey-128.3.0-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/spidermonkey/spidermonkey-128.3.0-r1.ebuild b/dev-lang/spidermonkey/spidermonkey-128.3.0-r1.ebuild
index 9b70f62cf9c9..625d0c4e282d 100644
--- a/dev-lang/spidermonkey/spidermonkey-128.3.0-r1.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-128.3.0-r1.ebuild
@@ -72,7 +72,7 @@ RESTRICT="!test? ( test )"
BDEPEND="${PYTHON_DEPS}
$(llvm_gen_dep '
clang? (
- sys-devel/clang:${LLVM_SLOT}
+ llvm-core/clang:${LLVM_SLOT}
sys-devel/lld:${LLVM_SLOT}
sys-devel/llvm:${LLVM_SLOT}
)
@@ -92,8 +92,8 @@ S="${WORKDIR}/firefox-${PV%_*}"
llvm_check_deps() {
if use clang ; then
- if ! has_version -b "sys-devel/clang:${LLVM_SLOT}" ; then
- einfo "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ if ! has_version -b "llvm-core/clang:${LLVM_SLOT}" ; then
+ einfo "llvm-core/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi