summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/c2ffi/c2ffi-11.0.0.20201113.ebuild')
-rw-r--r--dev-lisp/c2ffi/c2ffi-11.0.0.20201113.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-lisp/c2ffi/c2ffi-11.0.0.20201113.ebuild b/dev-lisp/c2ffi/c2ffi-11.0.0.20201113.ebuild
new file mode 100644
index 000000000000..3476bba406cd
--- /dev/null
+++ b/dev-lisp/c2ffi/c2ffi-11.0.0.20201113.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake llvm
+
+MY_COMMIT="07cda9bd315859d98bb4db83462952bb1bf5ea23"
+
+DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
+HOMEPAGE="https://github.com/rpav/c2ffi"
+SRC_URI="https://github.com/rpav/c2ffi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sys-devel/clang:11=
+ sys-devel/llvm:11=
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/c2ffi-${MY_COMMIT}"
+
+PATCHES=( "${FILESDIR}"/${PN}-10.0.0.20200527-add-target-link-directories.patch )