summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.50.0.ebuild')
-rw-r--r--dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.50.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.50.0.ebuild b/dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.50.0.ebuild
new file mode 100644
index 000000000000..0144b365625d
--- /dev/null
+++ b/dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.50.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=JROCKWAY
+DIST_VERSION=0.05
+inherit perl-module
+
+DESCRIPTION="create a temporary database from a DBIx::Class::Schema"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="virtual/perl-File-Temp
+ >=dev-perl/DBD-SQLite-1.290.0
+ dev-perl/SQL-Translator
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.360.0
+ test? (
+ dev-perl/DBIx-Class
+ >=virtual/perl-Test-Simple-1.1.10
+ )
+"
+PERL_RM_FILES=("MYMETA.json" "MYMETA.yml") # https://rt.cpan.org/Ticket/Display.html?id=108141